Cannot generate project files using VS2015

Hello guys, like the title says I am unable to create a new c++ project. Here is the exception log:

An error occurred while trying to generate project files.

Running C:/Program Files/Epic Games/4.10/Engine/Binaries/DotNET/UnrealBuildTool.exe  -projectfiles -project="C:/Users/wewan/Documents/Unreal Projects/DBTB/DBTB.uproject" -game -rocket -progress
Discovering modules, targets and source code for game...
UnrealBuildTool Exception: System.IO.FileNotFoundException: C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\Tools\../../VC/bin/amd64\cl.exe
   bei System.Diagnostics.FileVersionInfo.GetVersionInfo(String fileName)
   bei UnrealBuildTool.VCEnvironment.FindCLExeVersion(String CompilerExe)
   bei UnrealBuildTool.VCEnvironment..ctor(CPPTargetPlatform InPlatform)
   bei UnrealBuildTool.VCEnvironment.SetEnvironment(CPPTargetPlatform Platform)
   bei UnrealBuildTool.VCToolChain.GetVCIncludePaths(CPPTargetPlatform Platform)
   bei UnrealBuildTool.VCProjectFile.WriteProjectFile(List`1 InPlatforms, List`1 InConfigurations)
   bei UnrealBuildTool.ProjectFileGenerator.WriteProjectFiles()
   bei UnrealBuildTool.ProjectFileGenerator.GenerateProjectFiles(String[] Arguments, Boolean& bSuccess)
   bei UnrealBuildTool.UnrealBuildTool.GenerateProjectFiles(ProjectFileGenerator Generator, String[] Arguments)
   bei UnrealBuildTool.UnrealBuildTool.DoPostStartupStuffThatCanAccessConfigs(String[] Arguments)

Got the solution.
“In Visual Studio 2015, C++ tooling is no longer installed by default”.

While hte installation of VS choose custom instead of typical. Select other programming languages. In this case Visual C++ → Common Tools for Visual C++ 2015. If you already installed VS2015 you can just download the web installer and start the setup again to modify your installation.

Source: Setup Changes in Visual Studio 2015 Affecting C++ Developers - C++ Team Blog

EDIT: Another guy posted a question today where he was unable to install the common tools while he was using the express installer. You’ll need at least the “Community Edition” of Visual Studio.

Thank you. I was trying to open a 4.9 project with 4.10 preview and getting the same error. Your solution worked.

thanks. this also worked for me

UnrealBuildTool Exception: ERROR:
Failed to find cl.exe in the default
toolchain directory X:\Program Files
(x86)\Microsoft Visual Studio
Please verify that “Common Tools for
Visual C++ 2015” was selected when
installing Visual Studio 2015.

це працює! реккомедую.

It’s useful for me, Thanks~