Cannot find a compatible vulkan device that supports surface presentation error

Hi iam using UE4 on arch linux and I have vulkan and nvidia drivers installed but the luncher gives out this error “could not find a compatible vulkan device that supports surface presentation”
I tried to use the -opengl4 parameter but the engine gives out the same error
OS:archlinux (very recently updated)
Gpu:gts450
Gpu driver:390.144(latestfor the gts450)