Download

Cannot export 3D view from Revit 2019.2 using exporter

I just tried to export a scene using the 4.21E exporter and I am getting the following error: [TABLE]

Cannot export the active 3D view: An item with the same key has already been added. at Autodesk.Revit.DB.CustomExporter.Export(View3D view) at DatasmithRevitExporter.DatasmithRevitCommand.Execute(ExternalCommandData in_commandData, String& out_commandMessage, ElementSet out_elements)

Some help would be greatly appreciated as I am trying to get this scene into a walkthrough. Thanks!

If it helps, I tried this on another scene but that one was very basic and it worked. The scene I am trying is a developed project with lots of information and assets so I am not sure if that is impacting things.

HI there ,

Can I suggest that you try the new Datasmith exporter for Revit https://www.unrealengine.com/en-US/studio/downloads
4.22 Preview

Lots of fixes went into this exporter.
Not being in-sync with the version of Unreal you 're using ( I’m guessing you’re using 4.21) is not something we would usually encourage .
But, in this case . You should give it a try.
You just need to disregard the warning message on import.

Let me know if that fixed your problem

Cheers

So funny, I was thinking of trying this anyway since I thought I read somewhere else someone was suggesting to do the same for a whole different problem and it worked. I will try it and let you know. A little nervous dropping Enscape to use Unreal for my go-to program but I really want to do just that so I am hoping this sort of things are not too common. I just love working in enscape for some of the more interactive possibilities so I am very hopeful! Thank you for the response!