Download

Cannot enable "Use Emissive for Static Lighting" on object inside Blueprint

The checkbox for Use Emissive for Static Lighting is greyed out when I add a static mesh inside a blueprint. I can enable it for a static mesh in the scene, but not on a mesh inside a blueprint.

The reason to why I want the mesh in a blueprint is because I run an Event Tick script to change the emissive color. Is it simply not possible to use emissive as static lighting on objects inside a blueprint?

Same here! is there a possibility?

This works. Just select the Static Mesh Component and you’ll find the option in the listed under the Details panel in the BP. For this option to be enabled the Static Mesh component will need to be set to Static as well.

Thank you Tim - did not realize my static mesh components weren’t set to “static”. That solved my issue. :slight_smile: