Cannot Connect to Source Control

I’m trying to publish a project that my class is working on. Unfortunately, no method of in-engine source control is working. I must be doing something wrong, but, after reading every tutorial available I can’t figure out what mistake I’m making.

I’m using 4.7.4, so, according to the walkthrough, it’s just as simple as clicking connect to source control, choosing git, and then clicking accept. At this point I receive an error “Cannot connect to source control, check your settings and connection and try again.” I have no idea what settings this refers to, so, I’m not sure where to look. Connection is fine for everything else.

I tried using my school’s SVN server and I get the same issue. I’ve read the documentation for source control but I don’t see any hints. I appreciate any replies.


To import your project into source control, you first need to import it with a dedicated tool.
For instance, the creation of the Git project can be done in command line with the “git init” inside your project directory.

Also, my git plugin was not working with Mac in 4.7.x, see for instance:

There is also a wiki tutorial:

Let me know if this help!


I appreciate your reply, unfortunately running git init in gitshell (my global and were set when I did this as well) did not resolve my problem. I thought the problem might have been with my machine, so, I tried a different machine on the same local network but I ran into the same problems.

So, are you using a Windows 7 or Windows 8 64 bits PC?

Did you see anything special in the logs? See “Window->Developer Tools->Output Log”, and look for “LogSourceControl:” error messages

And can you post these logs here? You can find them in a *.log file in your project “Saved\Logs” subdirectory. I’ll look at it.

My machine runs Windows 7 64bit. Here’s the log when I try to connect:

LogSourceControl: RunCommandInternalRaw: 'git version'
LogSourceControl: RunCommandInternalRaw: ExecProcess ReturnCode=2 OutResults=''
SourceControl:Error: Error Failed to connect to source control. Check your settings and connection then try again.
SourceControl: Info Source control is disabled

When I saw that no version was being returned I realized I did not have the actual git binaries installed on these machines, just github’s interface with gitshell. My mistake! I had never actually used git for source control, just cloning projects and sharing some code with friends. Thanks so much for your time, everything is working now!

Yes, correct! So for the next version UE4.8 I have added auto-detection of Git binaries shipped with “GitHub for Windows”, but also with SourceTree and SmartGit :slight_smile:

Could you please explain exactly what you did? I can’t make it work, and I don’t quite understand what you did exactly?

I had to download and install git binaries. I got them here Git - Downloading Package

I did not have to set any environment variables, but, you might have to on some machines. Sorry for the delayed reply, I’ve been at Bonnaroo all week!