Cannot connect my account to Github

I needed to create a new Github account because of email unavailability on my older account and when I try to connect my UE4 account to Github inside my profile nothing happens. How can I can get access to the UE4 source code repository?

Edit: If I press on connect for Twitch for example, I get sent automatically to the page where I can link my account. But this doesnt happen on the Github one. :frowning:

What you are describing is odd.
You can always try to check your browser console to see if there is any error popping out. (Press F12)
Also, try this link to connect your github: Sign in to GitHub · GitHub
Make sure you are logged on your epic account at the same time.

Hi @ANameTooLongToFi, thank you for your answer. Your invitation was expired when I opened it. Could you sent me another one? This time I will check this thread every day.

I tried to debug the problem with F12, no errors pops up after I press Connect.

Edit: I uploaded a video showing my problem. As you can see if I press connect on Twitch or XboxLive I get redirected to another page, but not for the Github. :frowning:
Link: GithubConnectionProblem Temp - YouTube

The link isn’t a specific invite, it’s used to link your account in case the email isn’t sent.
Did you try using a different internet browser?
Can you open your browser developer tools and check if there is any error in the console or the network requests? (Press F12 to open the developer tools on your browser)

I tried different browsers, I have the same problem. As I said that nothing pops up as error on F12.

Sorry didn’t see you said you tried F12.

The only other thing I can think of is for you to try on a different network and computer if you haven’t tried already. Perhaps your network, firewall or anti-virus is blocking the authentication process.

I contacted Epics customer service and they helped me to just disconnect my Epic acc from the old Github acc. Now everything is working as it should be.

@ANameTooLongToFi Thank you for the help mate, I appreciate it! :slight_smile:

Hi everyone , i find the problem for me: just disable Ad Block. Just easy!


That was what worked for me.

1 Like

Sorry to necro but to any future people, adblock needs to be actually disabled for some reason, not just paused for the site.

You can right click it and pause for all sites and re-enable it when you are done. Not sure why.