Cannot complete installation: a file corruption has occurred

Hi I just subscribed to UE4 today

I use Windows 7 64bit

I have tried to install UE 4.1

Installation downloads file 2.7 gig then 0.7 gig and I receive an error : a file corruption has occurred

I tried to install it 7 times today
sometimes it’s just restarting on it’s own or I get that error.

I hope someone can help me

Hi Nihnu,

I am sorry to hear that you are experiencing this issue.

Have you attempted to re-download the installer from the UnrealEngine website yet?

yes I did redownload the main instaliation file from the website (44meg) it downloaded 2.7 gig of data then about 650 meg then started downloading another 2.7 gig and then installation failed : corrupted file

Me too, same here! link text

Hey,

Looks like this issue is popping up for a few people. From the logs it shows that for some unknown reason, either copying png files into your installation of the editor silently fails, or reading them back to check them fails. Due to this being exclusive to png files (which we do not treat differently to any other file) I can only guess at the moment that it is because of some anti-virus or data monitoring program you might be running? If possible could you let us know what you have that might fall into that category.

There is a hacky workaround that has helped at least one user, which is to make the installation keep trying just those png files only. It seems as though each time this workaround is tried it gets a bit further until eventually succeeding. The steps to setup this workaround are as follows, you will need to do this before hitting the install button:-

These steps are for windows. Please let me know if anyone with this problem is running OSX.

  1. Navigate to the editor install directory, by default this will be “C:/Program Files/Unreal Engine/4.1/” (or 4.0 if you are installing that instead)
  2. Create a new file named “$movedMarker”. This file should have no extension (yes, that’s a dollar sign!). Sometimes it might already be there, in which case you are good to go. You need to make sure your folder settings always show file extensions to know you made the file without one.
  3. You now have the following empty file, for example “C:/Program Files/Unreal Engine/4.1/$movedMarker”

If successful, when you click install, the process should begin counting progress with “Verifying Installation” and will then restart after 100%, only attempting to download and install any files that are still missing or corrupt. If this worked then you should notice that the downloading after verifying does not need to get the full 7.7GB.

Let me know how you get on! And don’t forget to post new logs please if you still have trouble.

Sorry for the inconvenience, I am investigating the cause of this issue but so far cannot reproduce it. If you could upload a dxdiag as well that might help me spot something.
Leigh

Hello Mr. Swifty,

I have already done that. I learned the “$movedMarker” from the other posts. It downloads like 90Mb and 50Mb and more 60Mb and still have the corrupted error. If you see my logs, I have already tried to run as administrator and all the time my anti-virus and firewalls was disabled.

I have manually checked the image files that are missing, the folder is never created nor the image files. I don’t know why it does not create this files.

My video driver is Catalyst and I have the AMD Radeon HD 7970. I’m only telling this because there are some programs that have problems with it. Do you still want me to send the Direct X log?

Thanks,
Igor.

Ahh ok. If it sometimes restarts with higher amount to get then there must be some issue being able to read the files back in after creating them as that suggests one run through they were fine but another they were not, even thought they would not have been touched. Could you let me know which antivirus software you have installed? Some that users have reported as troublesome are webroot and panda cloud.

I’m afraid all I can suggest at the moment is to try some more if possible, and I will continue to investigate as much as I can.

I’m using the “avast! Internet Security” paid version. I will try some more when I get home. I can run the engine manually using the editor .exe inside the folder, only the launcher is the problem. Let’s figure this out together.

Thanks,
Igor.

Thanks! I’m installing the latest avast! Internet Security 30-day trial to see if I can reproduce now

Hi Swifty,
Sorry for the delay. I tried 2 more times and did it, the installation is complete now, but now when I try to Launch it says “LAUNCHING…”, after that the “LAUNCHING” go back to “LAUNCH” and nothing happens.

Ok good news, sounds like you’re having a different issue now! Could you do me a favour and make a new thread for this so it is easier to track? If you could run the Launcher a few more times, hitting Launch button each time to repro the issue, and then upload your new logs to that new thread that’d be great. You can link to your new thread here so that I definitely don’t miss it :).

When hitting the Launch button, also if you can, keep an eye on the Processes list in task manager, and look out to see if the UE4Editor.exe appears, even for a second. Usually easiest to sort by Image Name and then it will appear right near UnrealEngineLauncher.exe and let us know. If it does we’ll probably need to see engine logs as well.

Hi Swifty, thanks for all your swift answers… =D I manage to solve the problem just by executing the Editor manually the first time and then the launcher correct it self. Sorry I didn’t manage to reproduce the problem so we can investigate for other users if they have the same problem. When I saw your message I have already solved the problem. I tried a lot of times before doing the manual execution of the Editor, the problem kept happening. I think maybe the problem was the PATH of my windows, since I moved the installation folder one time when I was uninstalling and reinstalling again and again to solve the “corruption” problem. I will look into my log files to see if there is any clue about what happened. If anything come up I will post here for everyone, ok? Thanks again for all your support.

No worries Igor :). Glad to hear you are up and running! Sorry again for the problems and thanks for your patience.

I’m having the same exact problem while trying to install the engine binaries. No change between launcher versions it seems. Tried the $movedMarker and -QFE2 (sp?) hotfix suggestions but they did nothing at all. I’ve run the launcher as full admin, disabled all firewalls and anti-virus applications but nothing seems to change the situation. I’m running on a fully updated version of Windows 7 on a 6 months old PC.

Are launcher log files and DxDiag exports “safe” to post here or can they contain sensitive information about my system setup (I’d rather not share such stuff with the general public)?

The launcher log states the next line as a fatal error near the end:
BuildDataGenerator: FATAL ERROR: EBuildPatchInstallError::FileConstructionFail, Could not create new file Engine/Plugins/Runtime/ExampleDeviceProfileSelector/Intermediate/Build/Win64/Dynamic/UE4Editor/Development/UE4Editor-ExampleDeviceProfileSelector.lib

@Nihnu & @ojrask

We apologize for the lack of follow up on this issue. Do you have any update on it? Is the problem still occurring for you, or were you able to find a solution?

Definitely please let us know if you were never able to get the editor to run, and we will be glad to investigate or discuss our options with you.

We are marking this as “resolved” for tracking purposes, unless we hear back from you.

Thanks

Mine is solved. This new laucher version solved my problem for good. Everything is perfect! Thanks,