Cannot Change Mesh of Physics Asset

I have setup a working physics asset on a test skeleton / skeletal mesh, my second pass skeleton / skeletal mesh has the same main bone names, but has some bones (that don’t have physics bodies) removed or renamed. I am able to select this physics asset on a new skeletal mesh using this new skeleton and it works when I play the editor, but in Phat i cannot choose my new skeletal mesh as the preview mesh using the Asset->Change Mesh menu. When I try, I get the error "The SkeletalMesh is missing bone ‘DELETED_BONE_NAME’ needed by this physics asset. The bone it says is missing does not have a physics body attached to it, and when I filter the hierarchy view in Phat to ‘Bones with Bodies’ it does not show up. I tried exporting my physics asset which created a text readable file, and every body that was in the original file when I imported the skeletal mesh is still listed even though I deleted most of them as they were not needed. I tried hand-modifying this file to strip out the un-needed bone references and re-import it buy it would not re-import. I would think that the physics asset would only care about the bone->body mappings that currently exist and allow me to change the preview mesh to any mesh containing the bones that are mapped. I noticed a right-click menu option to reset the physics asset, I am guessing that it preserves all these deleted bodies for this reason? If nothing else it would be nice to have the option to ‘create new physics asset from current state of existing one’ and then I could use that new physics asset.

After closing/re-opening the project, the Phat displayed a popup when opening my physics assets informing me that multiple bodies were referenced but not used and asked if I would like to remove them. Removing these bodies fixed the issue of not being able to change the mesh in the preview.