Cannot build UE5 on Linux - makefile error

Hello everyone!
I have been trying to build UE5 from the github repository for a week now. I follow the process to the letter (first executing ./, then ./ and finally make). However, when it’s time to build UnrealEditor and UnrealGame, I always get the same error that seems to stem from the GeometryProcessing plugin:

In file included from ~/Εφαρμογές/Unreal-Engine/UnrealEngine/Engine/Plugins/Runtime/GeometryProcessing/Intermediate/Build/Linux/B4D820EA/UnrealGame/Development/GeometryAlgorithms/Module.GeometryAlgorithms.cpp:23:
~/Εφαρμογές/Unreal-Engine/UnrealEngine/Engine/Plugins/Runtime/GeometryProcessing/Source/GeometryAlgorithms/Private/ThirdParty/GTEngine/Mathematics/GteTetrahedronKey.cpp:78:27: error: explicit specialization of 'TetrahedronKey' after instantiation
    TetrahedronKey<true>::TetrahedronKey(int v0, int v1, int v2, int v3)
~/Εφαρμογές/Unreal-Engine/UnrealEngine/Engine/Plugins/Runtime/GeometryProcessing/Source/GeometryAlgorithms/Private/ThirdParty/GTEngine/Mathematics/GteTSManifoldMesh.cpp:73:26: note: implicit instantiation first required here
    TetrahedronKey<true> skey(v0, v1, v2, v3);

Then, the makefile exits with error 6 (make: *** [Makefile:1203: UnrealGame] Error 6/make: *** [Makefile:1188: UnrealEditor] Error 6)

I have tried everything to make this work, but still nothing. I would be grateful if someone told me what I should do to make this work.

A thing to note: the version of UE5 I am using comes from the ue5-main branch, from the github repository.


Hello @MantisRoach,

I’m facing the same issue, did you find the solution ? :face_with_monocle:

Solved ! You are likely using the wrong version of UE5. Need to get the 5.0 from GitHub: Compiling the engine from source on Linux and getting a error of "make*** Error 6" - #7 by adx-s17