Download

Cannot Build UE4 Development Editor (VS 2019 Latest)


1>------ Build started: Project: UE4, Configuration: Development_Editor x64 ------

1>Creating makefile for UE4Editor (no existing makefile)

1>Building 8 actions with 16 processes...

1> [1/8] Module.Core.5_of_14.cpp

1>S:/UnrealEngine-4.25/Engine/Source/Runtime/Core/Private/Internationalization/Text.cpp(42): error C2375: 'FastDecimalFormat::Pow10': redefinition; different linkage

1> S:/UnrealEngine-4.25/Engine/Source/Runtime/Core/Private/Internationalization/FastDecimalFormat.cpp(715): note: see declaration of 'FastDecimalFormat::Pow10'

1>S:/UnrealEngine-4.25/Engine/Source/Runtime/Core/Private/Internationalization/Text.cpp(621): error C2065: 'Pow10': undeclared identifier

1>S:/UnrealEngine-4.25/Engine/Source/Runtime/Core/Private/Internationalization/Text.cpp(621): error C2568: '/': unable to resolve function overload

1> S:/UnrealEngine-4.25/Engine/Source/Runtime/Core/Private/Internationalization/Text.cpp(621): note: could be 'uint64 FastDecimalFormat::Pow10(const int32)'

1>C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Microsoft\VC\v160\Microsoft.MakeFile.Targets(46,5): error MSB3073: The command "C:\WINDOWS\System32\[chcp.com](https://chcp.com/) 65001 >NUL

1>C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Microsoft\VC\v160\Microsoft.MakeFile.Targets(46,5): error MSB3073: ..\..\Build\BatchFiles\Build.bat -Target="UE4Editor Win64 Development" -Target="ShaderCompileWorker Win64 Development -Quiet" -WaitMutex -FromMsBuild" exited with code 6.

1>Done building project "UE4.vcxproj" -- FAILED.

========== Build: 0 succeeded, 1 failed, 2 up-to-date, 0 skipped ==========


I have not change anything in the source, just downloaded, ran setup.bat, then GenerateProjectFiles.bat, then opened the solutions and tried to build the editor.

Was doing this to test building a dedicated server.

Hey, i have the same issue.
Have u got it to work somehow?

I think I may have resolved my issue, I had downloaded the source for 4.25, went to https://github.com/EpicGames/UnrealEngine/releases
and downloaded 4.25.3 and ended up installing VS 2017 and it appears to be building now.

I do still want to test with 2019

Hmmm okay, i had the issue with VS 2017 as well. I tried it with VS 2019 but it doesnt seem to fix it… I try to install 4.25.3 now