Cannot build ShaderCompileWorker

After building the latest git release branch on Fedora 29 I got the following error when running UE4Editor:

Couldn't launch .../UnrealEngine/Engine/Binaries/Linux/ShaderCompileWorker! Make sure you build ShaderCompileWorker.

Then I manually tried to build ShaderCompileWorker like this:

./Engine/Build/BatchFiles/Linux/ ShaderCompileWorker Linux Development -verbose

and received the following linker errors:

Performing 6 actions (10 in parallel)
[1/6] Link (ld)
.../UnrealEngine/Engine/Extras/ThirdPartyNotUE/SDKs/HostLinux/Linux_x64/v12_clang-6.0.1-centos7/x86_64-unknown-linux-gnu/bin/x86_64-unknown-linux-gnu-ld: cannot find crti.o: No such file or directory
.../UnrealEngine/Engine/Extras/ThirdPartyNotUE/SDKs/HostLinux/Linux_x64/v12_clang-6.0.1-centos7/x86_64-unknown-linux-gnu/bin/x86_64-unknown-linux-gnu-ld: cannot find crtbeginS.o: No such file or directory
clang++: error: linker command failed with exit code 1 (use -v to see invocation)
ERROR: UBT ERROR: Failed to produce item: .../UnrealEngine/Engine/Binaries/Linux/

I located the missing objects in


added these folders to LIBRARY_PATH, but the build still results in the same error.

export LIBRARY_PATH=/usr/lib64:/usr/lib/gcc/x86_64-redhat-linux/8/

Any help would be appreciated.


Is the toolchain complete? The file should be located at Engine/Extras/ThirdPartyNotUE/SDKs/HostLinux/Linux_x64/v12_clang-6.0.1-centos7/x86_64-unknown-linux-gnu/usr/lib64/crti.o

Please check that you have it there, and if you don’t delete the toolchain and run Engine/Build/BatchFiles/Linux/ again.

Thank you. I’m not sure while the toolchain was not complete first, but this fixed it.