Cannot build Blueprint project to iOS without remote build

I have an Unreal 4.17 Blueprint-only project on a Windows machine that I am attempting to package for iOS. However, when I attempt to package, I get the error message “Remote compiling requires a server name. Please specify one in the Remote Server Name settings field.” All of my certificates are valid, and are showing as green.

From what I can glean searching online, this should only happen if the project uses a third-party plugin. Currently, I am using only Built-In Plugins:

While I had the Substance Plugin installed to the engine at one point (which I know has been known to cause this problem), it has never been enabled in this project, and I have subsequently completely uninstalled the plugin from the engine and deleted both the Intermediate and Saved folders, to no avail. I have attached my [Output Log][3] for reference.

Can anyone recommend any solutions or next steps?

Bumping to see if I can get any feedback.

I have the same issue,everything was fine at first,I can launch the iOS game on my PC,but in one day morning I started my computer to go on my WIP project,output log show some errors below:

LogPlayLevel: ERROR: Remote compiling requires a server name. Use the editor (Project Settings, IOS) to set up your remote compilation settings.
LogPlayLevel: Doing xcode-select --print-path
LogPlayLevel: ERROR: Failed to start local process for action (“Cannot start process because a file name has not been provided.”): -o BatchMode=yes ${CURRENT_USER}@ “cd “/” && xcode-select --print-path”
LogPlayLevel: Took 1.036s to run UnrealBuildTool.exe, ExitCode=5
LogPlayLevel: ERROR: Command failed (Result:5): D:\Program Files (x86)\Epic Games\UE_4.18\Engine\Binaries\DotNET\UnrealBuildTool.exe M4VR_New IOS Development -Project=“G:\Unreal Project\M4VR_New\M4VR_New.uproject” “G:\Unreal Project\M4VR_New\M4VR_New.uproject” -NoUBTMakefiles -remoteini=“G:\Unreal Project\M4VR_New” -skipdeploy -ini:Game:[/Script/UnrealEd.P
rojectPackagingSettings]:BlueprintNativizationMethod=Disabled -noxge -generatemanifest -NoHotReload. See logfile for details: ‘UnrealBuildTool-2018.01.25-10.54.54.txt’
LogPlayLevel: (see C:\Users\Administrator\AppData\Roaming\Unreal Engine\AutomationTool\Logs\D+Program+Files+(x86)+Epic+Games+UE_4.18\UAT_Log.txt for full exception trace)
LogPlayLevel: AutomationTool exiting with ExitCode=5 (5)
LogPlayLevel: Completed Launch On Stage: Build Task, Time: 0.499973
PackagingResults: Error: Deployment failed! Unknown Error

I dont know what coursed this issue,can anybody here can help us?

Thanks for your answer!
Its weird that I could build iOS app without MAC somedays ago,because I use pure blueprint and there isnt any code and thirdparty plugin in the project,I read the document that showed I dont need MAC if I use blueprint.
I have no idea if this situation is caused by updating to version 4.18.3

Hi, first off you cannot build iOS on Window alone, you will need a Mac for remote build, and Remote Server Name refer to a Mac computer. Basically, Unreal on Window will send file for Mac to build game on Xcode then package game and send back Window an .ipa file.

Follow this guide if you want to package for iOS with remote machine. If not it’s highly recommend using a Mac to build for iOS.

It’s weird that it could build because you gonna need Xcode and Mac to sign certificate and provision, maybe just work for development build.
Another thing you could try is go DefaultEngine.ini and add this to turn off remote build



It’s enable by default.

Hi there,

We recently hit this problem, and after a lot of head-scratching have solved it.

To be clear you don’t need a Mac or XCode to get blueprint projects onto an iOS device.

What we think caused our problem was changing the Display name in the iOS settings.

To fix it for us, we:

  • deleted Saved, Intermediate, Build and Binaries folder
  • Tracking down changes behind the scenes, we found a couple of extra lines in Config/defaultengine.ini (under ios runtime settings). BundleDisplayName and BundleIdentifier had been set.
  • Deleting those two lines fixed the issue for us, in addition to deleting the folders listed above

Hope that helps!

Thanks Kenziko,

I have been having a lot of trouble with consistent iOS Launch / Build for my Blueprint project. Your advice solved my latest trouble nicely.

My complete solution was:

  1. Disable Slate Remote plugin (I use for touch input testing in editor)
  2. Delete the Saved, Intermediate and Binaries folder
  3. Removed the two remote build lines (RemoteServerName=10.x.x.x, RSyncUsername=xxx) under iOS runtime settings in the file Config/defaultengine.ini
  4. Clicked Build
  5. Clicked Launch (on iOS)
  6. Celebrate loudly

I have found the UE4 iOS documentation either omits many process variables, or is very ambiguous. There are also many mismatches between what is pictured in an image and the accompanying text). Without the community this would all be so much harder.

Thank you all.

Hi LoneScrapBot,

This is my thread in the forums trying to solve the same problem Forum link

Slate Remote plugin wasn’t enabled.
I deleted Saved, Intermediate only. I don’t have Binaries folder.
I opened the config file but the two rows that your are talking about aren’t there.
Do you have any ideas I would be very grateful.

1-make sure your project fully blueprint, no c++.
2-disable all third party plugins
3-leave all default enabled plugins to default
4-if you use Crypto disable it
uncheck any encrypt marks in Project Settings → Crypto( clear encryption and signings keys), uncheck Enable Pak Signing.
5-make sure your cert and provision (valid)
6-uncheck Enable Remote Shader Compile in Project setting → IOS
7-all icons in Project setting → IOS should be the default icons,
you can hack the engine by go to …\Engine\Build\IOS\Resource\Graphics\ first make a backup of this folder then rename all your icons to the same names in …\Engine\Build\IOS\Resource\Graphics\ and replace the default engine icons with your icons(they should be the same name and the same size) then go back to engine and go to Project setting → IOS → icons and click the little yellow arrow for all icons.

if you follow this infos you will be able to package for IOS from computer in shipping and distribution mode to app store.

I want to use VaRest for my project,and without Mac.Could u plz tell me how to solve this?