Cannot build a project. Editor Freezes

I think it is important to describe this issue as fully as I can. I have working on it for more than a week. I have done everything from changing drivers to reinstalling Unreal. I am working on an online unreal course, I really like using Unreal and as I have been a C++ programmer for many years, it really is my choice over other game engines. But, it aint much use in its current state and I am beginning to feel to walk away and look into other technologies for my planned project. I am really hoping someone can help get this working, as it stands I really cannot use the unreal engine. The Editor always freezes when doing a Build or just building Lighting or Textures.

I am pretty certain that the build worked up to some point. I believe the problem may have started when I tried creating an empty project and selected to use ray tracing. Since then it has not worked, just keeps freezing ( I havent used ray tracing since). Even through complete reinstalls, deleting folders and removing keys in the registry.

I have tried creating differant default projects: Empty, FPS etc. All projects are with the default templates and without any modification. All with the same results.

I searched the web and found many issues of this nature and carried out many recommendations found in those messages. All to no avail.

I uninstalled Unreal, deleted all relevant registry keys, %APPDATA% unreal folders, rebooted and re-installed etc… Unreal is now installed in the default folder. I have tried a differant folder outside of the boot drive also. Unreal projects are saved to a secondary drive. I disabled both Bitdefenders Firewall and Antivirus.

Here are some scenarios where I encounter the issue:

#1. Lighting build only. If an empty desktop demo project is created using default settings, remove furniture and desk light, so only empty platform is displayed with the shadows of the removed actors visible. Executing the Build → Lighting only. A progress dialog displays with a message: ‘connecting to swarm… (100%)’, after a minute it disappears, the cursor changes to a crosshair as though everything is complete. On the top/left of the viewport the message ‘Shaders Compiling (16)’ is visible. However the complete editor window is disabled, as though the windows message input queue is suspended. Nothing can be selected or executed. Only option is to terminate the task.

#2. Lighting build only. Loading the same project as in #1 and without deleting anything, the after ‘swarm connection… (100%)’ disappears a dialog in the botton/right of the editor displays a ‘Exporting lighting data: 33% Done’. It has a cancel button which cannot be pressed. As with #1 the complete editor is not responsive. Only option is to terminate the task.

#3. Full Build. Loading the above demo, deleting nothing, pressing the Build button. Dialog appears : ‘Building Texture Streaming (40%)’ along with a ‘Stop Build’ button. I have left this running for 17 hours and progress never increases. Pressing the ‘Stop Build’ button displays ‘Stopping Map Build (40%)’ and just sits there, never stopping anything. Only option is to terminate the task.

#4. I took a good look at SwarmAgent and SwarmCoordinator. I changed the output paths for both of them to a non writable protected folder. Looking at the log of SwarmAgent, it states that there is a certificate error however the job continues to launch. 2 Log files are produced, one of the states that SwarmAgent could not ping the SwarmCoordinator. SwarmAgent is listening on port 8009 and SwarmCoordinator is listening on port 26820. Both are in the Listening state. Note that my firewall is disabled. From withing SwarmAgent I could ping the remote agents but the coordinator failed to respond. I tried switching ‘EnableStandaloneMode=True’ and from the developer settings tab I tried LocalEnableLocalPerformanceMonitoring=True and False. I also tried the local process priority to AboveNormal. When Swarm was processing a job the progress bar in the Swarm Status tab just kept progressing exporting the scene. It did not move off this.

So, after all of this I am completly stuck. The problem I have is exactly the problem I had before my attempting to fix it. I would really appreciate if someone could help me solve the issue.

  • Main Computer Components:
  • MSI Z70 Godlike Motherboard.
  • 64gb Vengence RAM.
  • MSI GTX1080 ti.
  • Intel i7/8700k.
  • 1 x 4K monitor.
  • 1 x Hanns-G 1080p Monitor.
  • 1 x Benq 1080p Monitor.
  • All hardware overclocking disabled.
  • Windows 10 64 bit.
  • Bitdefender Internet Security.

Currently the latest NVidia 462.59 studio drivers are installed. I was using Game Driver 466.47 when the problem occured. I also tried game driver 460.89 and studio driver 460.89 both dating back to Dec 15 2020 based on another blog I came across.

If you got this far reading this lengthy description, then many thanks.

I downloaded and tried out the Unreal 5 early acccess. The problem does not occur when building lighting in that version.

Since this problem building a project began happening on UE4, I have been using UE5 without any real incidents. Yesterday I launched UE4 and created a new project. I was able to build it without any problems. I opened the project I was mainly working on in the above post and I was also able to build it (multiple times) without any problems. No changes were made, I had stopped using UE4. Problem fixed by a ghost!

1 Like