Download

Cannot build a blueprint project with plugins that have C++ code

I can build a project with blueprint only, but the moment I install visual studio 2019 I can no longer build anything. No matter if it is blueprint only. It says the binaries are not there to build for WIN64. I have gone through the different fixes that I have found on the forums here as well as reddit to no avail. Has anyone else run into this issue ?
Any help would be appreciated.

Can you please share the error message you are getting? Is the compilation itself failing, or do you not have all of the proper tools for compilation available?

The error may be in your projects logs (YourProjectRoot/Saved/Logs/YourProjectName.log) if you can’t find them elsewear.

Because I uninstalled and reinstalled UE5 the logs that I had are gone. So the step by step is
I installed UE5 EA2 ran into the same issues as everyone else it seems with the build ran the windows 10 SDK installer as well as the windows desktop runtime installer 3.1.15. was able to build BP only Projects with no issue.

The moment I added a plugin with C++ classes and went to build it said it needed Visual Studio. So I installed Visual studio 2019 as per the same install as I would for 4.26 ( in the 4.26 documentation). Opened the project back up and tried to package the project. It gave the error message that the binaries for WIN64 targets are not present. Took the plugin out and still ran into the same error on all projects until i uninstalled and reinstalled UE5 and uninstalled Visual Studio.

When you install VS 2019, you should make sure that you can go through the “desktop wizard” and create a simple Win32 windowed program, and build and run it, to make sure all the tools are correctly downloaded/installed. Just installing the IDE without going through that flow has previously left me in a state where it’s not quiet “prepped” to build C++ Win32 apps. (Whatever “prepped” means, I didn’t have time to debug)

The issue is that with UE5 all of that is out the window because 32bit has been removed. Can build stand alone programs and use VS with UE4.26 with no issues just something about 5 and 64bit that is not wanting to work properly.

So these are the 2 errors that I get if anyone has any ideas.

ERROR: Download support for building Win64 Game targets from the launcher

W64 target binaries not found