Download

Cannot add Add Movement Input node

I nuked my previous thread, as I realised the title was really misleading and it was super badly written.

Basically my problem is thus:
I’m attempting to write a basic movement blueprint from scratch for the sake of teaching myself. I have a game instance, game mode, game state, player controller and character pawn all set up and correctly referenced both in my settings and the game mode blueprint. I have my controls defined in Settings, and I can call InputAxis nodes, AddPitchInput and AddYawInput, but AddMovementInput is simply not there. I have tried all the various tips and bits of advice given on other parts of the forum and AnswerHub, but AddMovementInput is simply not there.
I have followed a bunch of fairly well-regarded tutorials on the matter, and I seem to be doing everything right in terms of setting everything up, but I simply cannot find AddMovementInput anywhere. I was initially under the impression that I needed to set up an AnimationBlueprint, but apparently this is not the case. I’ve been stuck on this for more than a day now. Any help or advice greatly appreciated.

Cheers!

Huh…weird…it’s right available in the Pawn for me–although my pawns are usually subclass of character, not just Pawn…so it might be only available that way. I am also still on an older build…so they might have moved it. Did you check/uncheck context-sensitive to see if it’s been miscategorized? That was hiding a bunch of nodes for me a few builds ago

I found the solution.

There are a bunch of tutorials on setting up movement controls out there that specify that you should implement your character’s movement logic on the controller class as opposed to the pawn itself. This does not work. I’m not sure if older versions of UE4 allowed you to implement that sort of stuff on the controller class, but it’s certainly not the case on 4.10. I imagine there’s probably a fairly simple way to pass input data from the controller class to the pawn in question, but I’m happy with that just now :slight_smile: