Cannot access TArray elements from external Class

I have external Pathfinding class that I need to use with UE4,
Everything is done, sampling the world … dealing with the class,
I had a problem using STL containers (the Engine crashed upon using them) so I had to convert to TArrays
After converting all the vectors/dequeus to TArray (considering functionalities and implementation)

I cannot access any of the TArray elements using the operator, however I can do this outside my external classes.

I have included the headers (some of) of the file in which the accession is working fine but with no luck too :S

A sample code:

	Node* x = NULL;
	x = m_pNodes[2];

this gives me the error:

error C2440: ‘=’ : cannot convert from
‘TArray’ to
‘Node *’ e:\studying\ue4\rts_ai
4.9\source\rts_ai\Pathfinder.h 120 1 RTS_AI

what is the type of m_pNodes?

Ohhh yes, you are correct.
As I was using vector’s at()
I missed that the TAarray was on the heap itself.

m_pNodes is TArray*

Problem solved … thanks :slight_smile:
x = (*m_pNodes)[2] solved the issue.