Download

Can you make finger movement change the direction of the camera?

My aim is for a finger to slide across the screen and the camera move in that direction. Please Help.

Thanks!

Seems to be popular on YT:

Good enough?

Thx so much

I watched it and did it in a new world and it worked. But in my main it is not working. I think its because I already have a controller but its just not working. Here are some images. Ask me if you need more images.


Is the touch code in that custom controller? Besides that, the image is too small to read anything (in case you wanted us to).

sorry for making it small. I will enlarge it

did you watch the video just a question. Because the person did not attach the code to the custom controller.

you can just click on the photo to enlarge it

please HELP

It’s 174px tall…

image

Not important though since you had it working anyway. So which blueprint is your script in now?

I tried putting the nodes in my custom controller and it still did not work! I am sort of new to coding and need a lot of help. I still do not understand why it worked it a new project but not in this one. If i imported all the assests from the new project and then imported into my main and then copy paste my code would that work? It would be very annoying. So is there anytging around this?
Kind regards,
Beaster2

Nodes are just text, so you can literally copy / paste them. You can even keep a library of useful stuff in the plain old notepad :slight_smile:

I tried putting the nodes in my custom controller

Other than that it’s somewhat impossible to wrap one’s mind around what is not working for you. We have absolutely no idea how you set things up and there are hundreds of ways to do so.

  • is touch working at all?
  • did it work before.
  • post the script:

You posted this and it really will not cut it.

For example:

image

This looks like a Branch with no condition. Perhaps it’s set to False and would never work…

here is a full big picture of my script

sorry for the bad quality

if i could send my project here

tell me what u think about that

When you copied the nodes, Tick turned into a Custom Event:

So either replace it with Tick or ensure Tick calls this event. If your Tick is already doing something else, you can Sequence the execution flow:

image

And you’re missing the condition check for the Branch and the Threshold variable. Also, ensure the variables hold the desired values.

Seems to be working OK:

I’d probably throw in a wee bit of interpolation / camera lag into the mix, though.


Also, you can edit posts, rather than add new answers.

I already have an event tick :frowning:

so is the event tick in the diagram the custom event?

thanks for noticing my errors