Can you always render occluded Paper2D sprite?

I’m making a 3D game with 2D characters. When the player walks behind some geometry I’d like to show the shape of the character in front of everything. A common technique, however I’m having some issues with using Paper2D sprites.
This is how the effect appears in the editor. Everything looks good as an emissive layer is drawn using Post Process and Custom Depth.

327869-desired.png

However, as soon as I play the game, hiding certain parts of the character (which are separate sprites) behind geometry hides those components. In this example image the same character is only showing the hat in the post process effect, because the hat is slightly sticking from behind the tree and thus isn’t culled.

327870-nope.png

As far as I’ve seen from tutorials and other users this doesn’t happen with anything except Paper2D Sprites. I can personally confirm that it works fine with meshes. Even a fully occluded mesh will be drawn. Is there any way to force the Sprites to render so they can be used for custom depth?

This is old, but I’ve come into this issue myself, and solved it.

The issue is in occlusion culling, so when the whole sprite is occluded, the engine won’t render it at all.

To fix this, go to your object (sprite, flipbook, etc.) and increase the parameter for bounds scale.

Read more about occlusion culling here: Visibility and Occlusion Culling | Unreal Engine Documentation