Can the UE4 Editor be run using Parallels on OS X?


I am currently developing a game that I want to deploy on iOS and Android. I’ve read on AnswerHub that Android deployment is (currently) limited to the Windows version of the UE4 Editor. All of my development resources are in OS X (i.e., Photoshop, Blender, etc.). I do have my MacBook Pro dual booted with Windows 8 on it’s own partition, but I’d rather not have to reboot my computer every time I need to switch over to Windows just to build out to Android.


Has anyone tried to use UE4 with Parallels on OS X, and if so, have you encountered any issues I’d need to be aware of before diving into getting Parallels?

Hi Jonathan, please see this thread. This is on our list of items to address.

Thanks for the quick response. I’ll make do in the meantime with using Bootcamp. I know there’s other, more pressing matters.

I’ve had a pretty hard time with it. Just started doing so now and I cannot for the life of me stand the slow screen scrolls. Of course, that’s when I actually can see the screen. Oftentimes there’s nothing but darkness. I may have to come up with something else…Please lemme know if Bootcamp works out. I’m stuck with running it on Windows since I have no way to code in the OS X version. Best of luck to you.

I’ve been running the Editor in Windows on my MacBook Pro using Bootcamp for over a year; on both Windows 8.x and Windows 10. However, I usually use the OS X version of the Editor. version 4.10.4 is super stable on OS X.

I’m assuming by a “way to code” you mean an IDE to program in C++ on OS X? If so you’re in luck! You can use Apple’s free Xcode IDE to program in C++ in OS X. You can get Xcode for free in the Mac App Store here: ‎Xcode on the Mac App Store

Parallel desktop just sucks in every aspect, it’s black!!

Is there a specific reason you are using UE4 with Parallels on macOS, instead of using the macOS binary version of UE4? I use the macOS binary version every day, on numerous projects, and it runs very smoothly.

I’m trying to build from source code for Google Daydream VR, and it never succeed on Mac… also if I build an Android VR app on mac it failed as well. Have you ever tried Daydream?

I haven’t done anything with Daydream. But I’ve done a lot of stuff with Gear VR and built successfully for Android on macOS. To build for Android on macOS, AndroidWorks should be installed. It’s in the Engine install directory (in 4.15-binary its under Engine–>Extras–>AndroidWorks–>Mac–>CodeWorksforAndroid-1R5-osx.dmg).

I’m actually building off of the Tegra Android Developer Pack (TADP), but support for that was discontinued by Nvidia, so Epic now uses AndroidWorks.

If the core issue is not being able to build for Android, you should start a new Question about it.