Can´t make VR Teleport work

Dear community,

I have created a level with the VR-template. I am using HTC vive.The HMD works and the Motion Controllers working too. The only Problem is: I cant use the Motion Controller Buttons to teleport to a Location. When I create an empty project with VR-Template and go to play in VR mode I am able to use the MotionControllers and the “teleporting” feature works very well. But after importing a own made level into the VR-template, I am not able to use the MotionController-Buttons to teleport in my own level. I would be very happy if someone could help me out.

I’m almost certain, but not entirely, that the teleporter uses navmesh… Try adding a “Navmesh Bounds Volume”.

Adding a NavMeshBoundsVolume doesn´t solve the problem.
I have downloaded the PolyPixel Freebie Pack. Then I started a new Project with the build in VR-template. I closed the saved project and added the PolyPixel Freebie Pack into the “new Project”.
Now if I open the VR-template map called Motion Controller the teleporting feature works very well.
But if I open the PolyPixel Freebie Pack and add a Motion Controller Pawn and a NavMeshBoundsVolume it doesn´t work.
I tried to set the world settings → Game Mode Override to None , still the same problem.
I have tried to copy the blueprints from the VirtualRealityBP–>Blueprints content browser folder into Freebie_01–>Blueprints content brwser folder.
Then I opened the Freebie_01–>Maps–>Demonstration map and added a Motion Controller Pawn and I can´t teleport.

My questions are: Does the content browser structure affects the blueprints? Does somebody have a good tutorial?
I already gone trough the Unreal documentation “Motion Controllers tutorail”, but I can´t make it work. Can someone send me some tutorial links facing this Problem, please?

This worked for me, but as a note that wasn’t as obvious to me as it probably should have been, make sure the navmesh volume OVERLAPS the areas you want it to map and doesn’t just butt up to them.

in case the problem still exists:

after adding the navmesh bound you`ll need atleast one “Nav Modifier Volume” at one side of your map inside of the bounds volume.
A simpel “wall” or “floor” should do the trick, it did for me atleast.

Without wanting to sound like an complete ■■■ but deconstructing the VR template map until it stops working could give you a pointer waht you need in the map to make it work, than go from there

hope that helps

If you open the motioncontrollerpawn in the editor, you will notice the “compile” button. If you see a yellow exclamation mark, that means there are errors in the compiling process. Normally, this is due to the “input” in “project settings” not having the motion controller buttons assigned properly. That is, the buttons that enable you to teleport must match the input setup in the project settings.

I am facing the same problem in spite adding the navmeshvolume , still not able to teleport (am using Oculus), is this issue solved?, can anyone please help me out!
Thank You in advance

anyone find a solution ?

Im struggling as well, just added the nav mesh bound and modifier but even when I show the volume Im not getting anysort of colour to tell me it working. if anyone can point men in the right direction that would be great, Im using uneal engine 5

I found it! Guys if you are trying to test it in a brand new level, try deleting the floor and add a new one. (anything works, scale up a cube). It works perfectly for me now.

Make sure you:

  1. Finished setup VR pawn
  2. Added a navmesh volume that is overlapping the surfaces

it work!thank you sooooo much!!