Can someone Help me with this Error.

Hi, idk what this Eroor means or how i can sove it :frowning:
This is my Blueprint:
Screenshot 2022-12-30 112714
and this is the message:

Pls Help me :confused:

I think you’ll find that cast fails?

Did you specify your game instance in the project settings?

1 Like

yea i did, i have checed it twice Xd

How did you make your game instance? ( is it a child of the main GI? )

I, made a new Blue print calass (Gameinstance) and then i go in the settings and yea…

Can you put a print string here


Does the cast fail?

Still the Same Error

I know what it is.

When you let go of E, the top half of the graph does not exist.

You need to get the game instance on the ‘release’ part as well…

Wait i will try it

Also: ‘open level’ trashes everything that is happening. Any code running - trashed.

So once that open level runs, you can’t let go of E.

I answer a question about how to do this yesterday, hold on…

Like this?

Ah, it was you! :slight_smile:

I will show you the code…

I know but it doesnt work ? idk why

it says that i have to make the player capsuel moveable but its loked

You’re missing the point. The moment THIS runs

All the rest of the code is binned.

You have to move the player in the new level. Gimme 2…


Maybe for a few ticks, but then it gets binned…


Yea if dont switch the map the code works :confused:

This is how you do it.

In the first map level BP

See, I put the player location in the GI, but ‘open map’ immediately starts the new map. It’s a different map, no chance of setting the player location from this map.

So, in the Level BP of the NEW map, I have


Oh ok i will try thx ^^

OMG it worked thx you are my hero ^^



1 Like