Download

Can someone help me make a neon glow material that affects the environment?

Can someone help me please make a neon glow material that affects the environment? I thought I had it because my mesh glows from a distance, but when I get closer it looks like plastic with no glow lol.

Hey N0M4D, everything Black Master said is incorrect

To create your neon sign so it glows and illuminates the world you would create a new material with the a ThreeVector tied to your Emissive input, you would then mask this ThreeVector by multiplying it by a texture mask (this would separate your bulbs from the rest of the mesh so you don’t have to use multiple materials, you could also utilize the new Material Layers features if you like)

The higher you make the numbers in your ThreeVector adjusts the amount of glow (123 = RGB) given off by the material, usually somewhere between 50 and 100 for each color is good for a neon sign

Now you want to select the Main Material Node and go under **Details **and expand the **Material **tab then at the bottom of the Material tab there is a little icon that looks like a downward pointing Eject Symbol, click that to get advanced settings and then check the option for Use Emissive for Dynamic Lighting area - You can also just type **Emissive **into the details search box to get there faster

Now your emissive material should glow and illuminate the world as well - You will end up with something like the below

http://s27.postimg.org/y2hc8jo77/Neon.jpg

CharlestonS is Correct, I wonder why Black Master even bothered to post here.

Anyway think of it like any value in RGB (vector3) that is >1 will start making your material brighter and brighter to the glowing point, If you wish only a certain area to glow then you need a mask just like CharlestonS said.

Make a note however (at least, this was the case during the beta, so I’m not sure if it’s changed publicly), that the old system where you could actually cause emissive objects to be considered in the lightmass build is no longer there.

It is there but it’s not in the mesh properties anymore, it’s in the Material properties but as far as i can tell it’s only available as a Dynamic light, not static

Thanks for the reply Charleston. Could you please post a quick pic of the blueprint? My entire model glows (which is what I want) but it’s not affecting the environment. I checked the box on the material node too. Thanks in advance.

Ehh… no it doesn’t.

I made a material and put 50 50 50 in emissive, checked that box and put a chair next to the object like you did… the chair is pitch black.

All I see is: some SSR, some Reflection Environment (maybe that is what you perceived as light?), some Lens Flare, and some specular highlights - no actual contribution from the emissive to the lighting.

Emissive doesnt emit light, not the slightest, and definitely NOT on dynamic objects( i think lightmass can bake light from emmisive in static objects, but not completely sure)
If you want your character to glow and emit light, add ligths to its blueprint, currently no engine in the market (only UE4 with that voxel illumintation) can do that.

The emissive properties of materials only appear to the renderer (for i.e. post bloom & reflections). The have no diffuse emission at all, and Lightmass doesn’t receive lighting from them (as TheJamsh pointed out).

https://answers.unrealengine.com/questions/5498/question-using-emissive-for-lighting.html

Three days in and everything was going so well :confused:

I’m considering using point clouds generated in Houdini to spawn lights (to get an approximation of emission coverage) … easy to accomplish in a DCC, not sure how well Lightmass will handle it. It would be a lot easier if Houdini Engine were available in UE4. ahem :wink:

This is the part where I grin knowingly.

Emissive does emit light to the LightPropogationVolume when you enable the feature in the material properties and adjust the settings under your PostProcessvolume, UE3 supported this as well but only through the static lighting channel, now it supports dynamic

Make sure you PostProcessVolume is Unbound (Affects world) and that you adjust the settings correctly

I will post a quick tutorial on this when i have some time but for now just mess around with it

We all definitely appreciate your help Charleston. However, if you could post a quick pic of the blueprint, it would greatly help us.

All the best,
Randy

Haha, I see you matey : )

2014 is turning out to be a great time to be a game dev.

Ahh that’s interesting and a solid excuse to check it out. Applied to lightmaps is still my primary concern though as these have an immediate application, and importantly aren’t limited to the best hardware (particularly OpenGL ES targets). Defo going to take a look though.

PostProcessVolume is Unbound where is this located exactly? I searched with 0 results.

Select your **PostProcessVolume **(you can just select it in the Scene Outliner)

Then make sure you have the Details tab open and expand the Post Process Volume section of the details pane and **Unbound **will be the last option

Found it but it still isn’t working…I’ll wait for your tutorial.

I do hope we get this to work…

Any tutorial on this yet ? :slight_smile: