Download

Can someone figure out why this works in third person template but not in top down

I am having an issue here and I can’t figure out why. I cannot get the camera boom/swing arm component to move in the top down blueprint template. I used the picture below in both templates and in the third person template, it works wonderfully. In the top down template, the camera will not move. I figure there has to be some way the camera is locked in the top down but I’ll be darned if I can find it. Can anyone figure this out?

de7f9c608a1df51a6a1dd9cc2e48d3ae3a5563e2.png

The first thing I notice in your blueprint, have you changed the target to SpringArm1 in your top-down version?

&stc=1

yes, in the third person, it is the camera boom, in top down it is swing arm

I should also mention, I put a sequence in after mouse wheel down and threw in a print string. It would not print anything. Also, I tried to change mouse wheel down to “Z” key press and it also did nothing and printed nothing. Maybe it is something with inputs being blocked and not anything to do with the camera at all?

The only other differences I see for the CamBoom/SwingArm components are under Camera Collision and Camera Settings:
Camboom has: Use Controller View Rotation ON and Do Collsion Test ON

Yeah Inputs came to mind under Project Settings>Input 3rd person seems to have a Mouse Y mapped to look up…but that would be weird if that changes something. Maybe Add a mouse scroll input in the Axis mapping list?

This is great learning for me too and I also wanted a camera zoom in Top-down, I was actually checking out the strategy game example to see how they did it in there, I’ll go and replicate your blueprint in the meantime

Yeah I was happy that I thought I actually figured out how to do something on my own for once without help from the internet. I had a similar blueprint to this one drawn up, basically except for using variables, I just had values plugged in to the math nodes. It wasn’t working so I did some internet research and found this blueprint and found out it still wouldn’t work. That was when I knew it wasn’t something I was doing that was the issue. I will keep trying to figure this out. I would ideally like for this camera to be able to zoom in and out and when it gets down to its lowest point, have it rotate down be horizontal.

Eureka! :smiley:

So it’s not your blueprint at all. I’ve tested it in the 3rd person and it worked perfectly. I had a final suspicion the MyController blueprint was interfering and it was!

so here’s the fix:

Got to MyController Blueprint>Defaults tab and uncheck **Block Input

**

&stc=1

Genius! Works fantastic! Thanks.

Np, thank you too!