Download

Can not open project with C++ error

[FONT=Helvetica Neue]When I try to open a C++ project I meet this error message. I use Windows 10, and I tried reinstalling both Unreal 4.25 and VS, the error persists. It asks me to continue with Visual Studio 2019 also, here is the error message:

Running C:/Program Files/Epic Games/UE_4.25/Engine/Binaries/DotNET/UnrealBuildTool.exe Development Win64 -Project=“C:/Users/Cem Tuğanlı/Documents/Unreal Projects/MyProject/MyProject.uproject” -TargetType=Editor -Progress -NoEngineChanges -NoHotReloadFromIDE
Creating makefile for MyProjectEditor (no existing makefile)
@progress push 5%
Parsing headers for MyProjectEditor
Running UnrealHeaderTool “C:\Users\Cem Tuganli\Documents\Unreal Projects\MyProject\MyProject.uproject” “C:\Users\Cem Tuganli\Documents\Unreal Projects\MyProject\Intermediate\Build\Win64\MyProjectEditor\Development\MyProjectEditor.uhtmanifest” -LogCmds=“loginit warning, logexit warning, logdatabase error” -Unattended -WarningsAsErrors -abslog=“C:\Users\Cem Tuganli\AppData\Local\UnrealBuildTool\Log_UHT.txt” -installed
Reflection code generated for MyProjectEditor in 6.2865605 seconds
@progress pop
Building MyProjectEditor…
Using Visual Studio 2019 14.26.28806 toolchain (C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\VC\Tools\MSVC\14.26.28801) and Windows 10.0.18362.0 SDK (C:\Program Files (x86)\Windows Kits\10).
Building 15 actions with 12 processes…
@progress ‘Compiling C++ source code…’ 0%
@progress ‘Compiling C++ source code…’ 7%
[1/15] ERROR: Unable to open C:\Users\Cem Tuganli\Documents\Unreal Projects\MyProject\Intermediate\Build\Win64\MyProjectEditor\Development\Engine\SharedPCH.Engine.ShadowErrors.h.txt.tmp for output
@progress ‘Compiling C++ source code…’ 13%
[2/15] Default.rc2
fatal error RC1109: error creating C:\Users\Cem Tuganli\Documents\Unreal Projects\MyProject\Intermediate\Build\Win64\UE4Editor\Development\MyProject\Default.rc2.res

After I searched for this in the C drive: C:\Users\Cem Tuganli\Documents\Unreal Projects\MyProject\Intermediate\Build\Win64\MyProjectEditor\Development\Engine\SharedPCH.Engine.ShadowErrors.h.txt.tmp for output

the error message was converted into this:

Running C:/Program Files/Epic Games/UE_4.25/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project=“C:/Users/Cem Tuğanlı/Documents/Unreal Projects/MyProject2/MyProject2.uproject” -game -rocket -progress
Discovering modules, targets and source code for project…
ERROR: Failed to launch compiler to compile assembly from source files:
C:\Users\Cem Tuganli\Documents\Unreal Projects\MyProject2\Source\MyProject2\MyProject2.Build.cs
C:\Users\Cem Tuganli\Documents\Unreal Projects\MyProject2\Source\MyProject2.Target.cs
C:\Users\Cem Tuganli\Documents\Unreal Projects\MyProject2\Source\MyProject2Editor.Target.cs
(Exception: System.ComponentModel.Win32Exception (0x80004005): The system cannot find the path specified
at Microsoft.Win32.NativeMethods.CreateDirectory(String path, SafeLocalMemHandle acl)
at System.CodeDom.Compiler.TempFileCollection.CreateTempDirectoryWithAce(String directory, String identity)
at System.CodeDom.Compiler.TempFileCollection.GetTempFileName(String tempDir)
at System.CodeDom.Compiler.TempFileCollection.EnsureTempNameCreated()
at System.CodeDom.Compiler.TempFileCollection.AddExtension(String fileExtension, Boolean keepFile)
at Microsoft.CSharp.CSharpCodeGenerator.FromFileBatch(CompilerParameters options, String] fileNames)
at Microsoft.CSharp.CSharpCodeGenerator.System.CodeDom.Compiler.ICodeCompiler.CompileAssemblyFromFileBatch(CompilerParameters options, String] fileNames)
at UnrealBuildTool.DynamicCompilation.CompileAssembly(FileReference OutputAssemblyPath, HashSet1 SourceFileNames, List1 ReferencedAssembies, List`1 PreprocessorDefines, Boolean TreatWarningsAsErrors) in D:\Build++UE4+Licensee\Sync\Engine\Saved\CsTools\Engine\Source\Programs\UnrealBuildTool\System\DynamicCompilation.cs:line 254)

EDIT:
THE PROBLEM HAS BEEN SOLVED: The problem was non-english characters on my user/home directory name. I solved this by changing my name in user/home directory. I opened a new user account on my computer with a name without non-english characters, and deleted the old one. I can now open projects of C++ cuz the programm can read my user/home directory name.

Have you tryed to refresh VS project from UEditor? Pretty same problem was for me when I’ve switched version from 4.24 to 4.25.

THE PROBLEM HAS BEEN SOLVED: The problem was non-english characters on my user/home directory name. I solved this by changing my name in user/home directory. I opened a new user account on my computer with a name without non-english characters, and deleted the old one. I can now open projects of C++ cuz the programm can read my user/home directory name.

Wow, thanks so much. Saved my life with yourtip