Can not open Epic Games Launcher (Mac)

I’m getting into game development, and I tried downloading Unreal Engine. However, I got stuck when opening the Epic Games launcher and I got this message: “Please Wait While We Start Your Update” and an icon below saying: “We’re sorry. It looks like we’re having trouble connecting. We’ll continue to retry.”

I’ve tried to Uninstall-Reinstall, I’ve done everything on the " Troubleshooting the Epic Games Launcher" page. I’ve looked on the forums and haven’t found a solution.

I’m open to all possible solutions, I just want to be able to make games.

After leaving my computer for a few days the problem fixed itself, now I can’t sign in, I just get the error code: EC-MD-HSH

Hello Pixilated_Sun, I hope you are well.

I took a gander at the error message you have received and found that the following error may be similar to yours: SU-MD-HSH: Failed to asynchronously deserialize a manifest. This error occurs when the launcher tries to asynchronously deserialize a manifest when there is a mismatched hash value.

The link I have provided contains a step by step guide into correcting the error.

I hope this information assists you.

1 Like

Thank you @Polite_Muon for your help, however, this solution did not work. I still get the error message EC-MD-HSH. I am still open to suggestions, and when I have time I will try and find my own solutions.

Edit: I also believe that the error codes EC-MD-HSH and SU-MD-HSH are similar, however, I think that the source of the problem is different, while the results are the same.

I am attempting a fix where I delete EVERYTHING in my files with either Unreal Engine (Because I’ve tried to get Unreal a year or two ago) or Epic Games Launcher in it. I have redownloaded the Epic Games Launcher. I now have the “Please Wait While We Start Your Update” glitch. I will give my systems time to redownload the updates and see if the EC-MD-HSH problem persists.

Would like to add, the solution suggested in works perfectly

This reply might be a bit late. The issue stems from a security stand point, when you are directed to the browser the browser stops sending the information back to the application. In order to fix this and if you are using Safari you need to turn off the security feature of the browser go to Safari Preferences> Privacy>unselect “Prevent cross site tracking” and “Hide IP address”. This should allow the browser to communicate back to the application and/or send back information to Epic servers.

I’m running M1 Mac and doing this worked, just make sure you turn security features back on after login in.

For anyone coming across this issue currently, I’d recommend first going in and taking the steps that Pixilated_Sun did in the last post. Go into your EpicGamesLauncher/Saved (On MAC you’d go to Library>Caches) and delete any of the Unreal Engine/Game WebCaches. I’d also recommend a reboot of your modem and router. These are common fixes for this specific issue. If those steps don’t work, then perhaps look into bypassing your firewall/security to see if it’s being blocked.

It worked for me as well! I wasn’t able to access my account for years because of it and even lost an old account with a library on it but this fixed it. I skipped step 2 as I couldn’t find the mentioned folders, so I just opened engine.ini in finder