Can not go fullscreen in play in editor

I am trying to go fullscreen in play in editor. I have tried F11, shift+F11, alt+enter, and Fullscreen console command but nothing works. If I push F8 to eject, I can use F11 to go fullscreen but only while I am ejected from the player. Is this a known bug or is there a way to fix it?

Also, when I press escape while in play in editor, it will not exit play mode and take me back to the editor. I’m not sure if this is related though I have a feeling it might be.

Hi EMcNine,

Please tell me about your system specs. If you are on a PC, please provide your Dxdiag. If on a Mac, you can find this in the Apple menu >About This Mac>More Info> Add the information from this window (serial # not necessary).

Thanks

I am on a PC. Windows 7 Professional 64-bit. I have attached my DxDiag text file. Another co-worker is using the same computer build as I am but is not having this problem. I have tried unplugging the Oculus from my machine (the only difference between the two machines) but it didn’t change anything. I have also tried creating a blank project and it still has the same problem.

Try restarting the editor with the Oculus unplugged and see if it works. If not, what happens when you press f11? Nothing? or do you get a black screen etc.? Let me know -thanks

Restarting the editor with the Oculus unplugged didn’t change anything. I still get the same results. If I’m just in the editor, F11 goes fullscreen like normal but as soon as I am in PIE, F11 does nothing at all. The screen doesn’t go black and there are no visible changes anywhere.

Please follow the steps on the following link, particularly regarding installing the lastest runtime driver:
Sanity Check

I followed the instructions, updated the Oculus drivers, and updated the NVidia drivers but the F11 key still does nothing in PIE. Just to be clear, I have no problems with the Oculus but I am not trying to get the Oculus to work. I am trying to figure out why my normal keys (Esc, F11, etc…) do not work with in PIE.

Thanks for following those troubleshooting steps. Almost all issues reported for “Cannot Play in Editor in Fullscreen Mode” have had some connection to the Oculus, hence the focus there. However, that does not necessarily mean that is the case this time.

Another cause has been a conflict with the software: “TeamViewer.” Are you running this software on your machine or something similar? I am still looking into this but that is something you can check in the meantime.

I have TeamViewer on my machine but it is not running. I don’t have any similar software on my machine.

Please open the task manager, sort processes by name and verify TeamViewer system processes are not running: If so, close them and restart the Editor to test fullscreen:

TeamViewer is not running in my processes. I also tried rebuilding the engine but I still have the same result.

Hi EMcNine,

Please try this: Open Teamviewer. Options>Advanced>Show Advanced Options>QuickConnect button>Configure. Add …\Program Files\Epic

I tried it this morning. I added the editor to the list of programs to ignore, double checked to make sure team viewer is not running, and restarted the editor but I still can’t go fullscreen.

Hi EMcNine,

Teamviewer is listed as software known to have a (minor) conflict as listed here: Software Conflicts and the issue is that it “keeps Unreal Tournament from running fullscreen.” While not reported for the editor yet, it seems a little too close to ignore this correlation.

Since the software may have already made adjustments to the editor, you can try (closing the editor) and deleting the Derived Data Cache folder located here: User/username/Library/Application Support/Epic/UnrealEngine/4.8/DerivedDataCache

If this does not resolve the issue, you can try uninstalling Teamviewer altogether (if you can reinstall later at no cost to you), deleting the DDC folder, and restarting the editor.

Let me know if any of these resolve the issue. -Thanks

Hi Steve,

I tried all of the above suggestions and they all produce the same result.

Here are some additional things to consider:

  1. If the viewport where you are Playing In Editor is not docked to the editor, that is to say, floating as its own window, it will not go into fullscreen when pressing f11. The window must be docked in the editor for this feature to work.
  2. Check your Nvidia Control panel to see if the 3D settings are optimized for UE4, particularly Multidisplay settings
  3. Since there has been reports of the Oculus conflicting with fullscreen mode, you may try uninstalling all Oculus software temporarily as a troubleshooting step.

I tried all these suggestions but still have the same result.

With Teamviewer and Oculus software uninstalled, update Engine to 4.9.2 When this is complete, press down arrow by Engine Version and select “Verify.” After verification, open a brand new project and test Fullscreen while in P.I.E.

-I I also meant to ask if this only occurs in the 4.9 version of the Engine? Please test this in previous versions if you have them installed. If you do not, please temporarily install 4.6, 4.7, and/or 4.8 and test Playing in editor, full screen.

Hi EMcNine,

We have not heard back from you in a while so we are closing this post for tracking purposes. If you are continuing to experience problems with the editor not entering fullscreen while Playing in Editor, please respond with the requested information after following the last advised troubleshooting steps.

Be advised you will only be able to go fullscreen by pressing f11 if you have chosen “Selected Viewport (PIE)” as shown below (Otherwise known as Immersive Mode which is selectable also from the dropdown menu in the Viewport):

61883-fullscreen.png

If you have selected “New Editor Window (PIE)” there is no Console command to go fullscreen but you can workaround this two ways: Console Command: r.SetRes [YourMonitor’sNativeRes -noBrackets]f example: r.SetRes 1920x1080f

or In Editor Preferences/Play/Play in New Window: Change the size to your monitor’s native resolution

Finally, if you choose the Standalone Game, you can use the Console Command: fullscreen to enter full screen.

I realize these alternates may not be a solution to the issue you are experiencing, but hopefully they will provide a workaround until we can determine the ultimate source of the issue.

On your viewport click Perspective > Default Viewport. Then hit F11. Fullscreen doesn’t work on Cinematic Viewport.

I had the same problem and just figured out.