Download

Can not delete player camera component and playerstart spawning duplicate players

My player character’s viewport shows two cameras. One is the camera that I added and the other is waist high. I’m using the ue4 mannequin for the player. I can not delete the camera that is waist high, cannot even click on it.

I was adding new code under the event graph and when i tried to test my game, four four copies of my player spawn at my player start. My world outliner also shows multiple players and player controllers spawning. None of the code I was trying to add involved cameras or player controllers. I’m not sure if this camera that i can not delete is causing the issue. I removed all the code that I was working on and now am back to how the game was before this issue started. My project is blueprint only and I’m on 4.14.

I had this happen before with the two camera issue and the only fix was to rename my player, create a new one and redo every reference that it is called. It took all day to fix and I would hate to have to recreate it, again. It’s the first time I’ve ever spawned myself multiple times though.

I’ve check project settings, level blueprints, player and controller blueprints and everything is still how it was when I had a working version. Any help would be appreciated!

You need to tell your pawn (one you placed in level) to AUTOPOSSES player 0. Unreal does not know you want pawn that is in level to be possessed by player, so it spawns default pawn (or one you set in project settings) for player 0. That makes 2 spawned pawns, one you placed in level and one unreal spawned for player.

Autoposses is property in details panel of pawn, so click on your pawn in level and find autoposses in details.

Of that is not the case i am afraid you need to show your code.

Thanks for the reply! I tried that and it didn’t work. I didn’t take a picture, but i also spawned three more duplicates of myself to my right about 100 meters out so six players spawned randomly over my map. I found through google someone else had something similar happen with the camera issue. It was cause by adding a component, deleting it and restoring it using control z. I’m not sure if that is what happened but I was able to restore from a previous backup.