Can not compile anyting related with C++ Exception: System.IO.DirectoryNotFoundException: Could not find a part of the path

I can not create a C++ class, can not create a C++ project and can not compile my C++ classes on my existing projects. When trying to create a C++ project I’m getting this error:

Error log

I tried to:

Reinstall the engine, reinstall the VS, reinstall the engine to another drive, reinstall the VS to another drive, remove regedit keys of UE4, give full permission to TEMP folder for my windows user, try to run everything as administrator

Been trying to solve this for 2 days sleeples but nothing was helpful. Thanks for reading.

I had similar problem with accent in my user name, but your path:


does not seem to have any one…maybe try with another user ?

I dont have any “fqgubmrn” folder in temp. But yes, my username is Kullanıcı and it uses “ı” and it doesnt exist in English, but compilers and some setup folders create new one with “i” and use it without any trouble. I was able to use Kullanıcı without any problem with UE since this problem appeared.


I will try to change my username or try with another user

I also found my UBT log about the path error: link text


this path is mentionned in your first log.

Try to create at least the directory and an empty .tmp file.

Its solved!! I realized Windows (or UBT) treats as an user and my current user (Kullanıcı) can not access the first one. I tried to make the temp folder of shared and gave full access to my user. Now I am able to compile anything. You made me realize the problem, thank you very much!

I am happy that I could help you !!