Can I just plug in a ps4 Controller?


I’m wondering if I can just plug in my ps4 controller into unreal and have it work? I tried enabling the windows raw input plug-in and I set up all my axis’… I got the jump (X button) input to work, but the left and right stick axis’ are all messed up, if my scale factor is set to anything above 0 my character is infinitely moving forward. Instead of moving forward when I push up on the left stick, if I push my left stick up then my character stops moving… please help

Do you really need any of that Generic USB Controller Axis, i think i’ve head it works fine just plug and play and use the standard GamePad Left / Right Thumbsticks X and Y

It may be something with your input settings, try it with a clean Third Person Character Example Project with just plug and play. That has all the Gamepad Left X and Y settings you need to move and Gamepad Right X and Y to rotate camera

Yeah for some reason it doesn’t work just plug and play for me. I’ve used my controller on my pc, I downloaded apex legends and it worked fine there. When I plug it in to Unreal there is no input at all but my pc recognizes the controller. I searched for answers for hours and found almost no one talking about it so I started to think maybe it’s something with me. Is there a certain way I’m supposed to plug it in? Maybe after I hit play? I’m sorry if this is something super easy I’m overlooking, I’ll get back to experimenting when I get back to my computer.

I just tried it with a clean third person example map, plug and play still doesn’t work. I even tried bluetooth pairing my ps4 controller to my pc, it works when I look at the gamepad properties in windows and when I look at my project settings all of the input maps are correct, gamepad left x and y are in the right slots. I even messed with my gamemode settings, I feel like it should be working.

hmm it seems to be working for the others there, maybe something has changed compared to 4.23 which was the latest one when the post was made.

To be honest i recommend just getting a Xbox One controller to avoid any unpredictable problems that occur. You never know if some plugin or something you want to use in the future has some check for just xbox one controllers and doesn’t support ps4.

Xbox one controllers goes for pretty cheap used, and can be connected to PC with just a Micro USB Cable

YES!!! I Figured it out!!! It’s a little finicky but I think I can dial it in now. ugh what a relief. It’s the offset, in 4.24.3 the offset must be bugged. but in 4.25 it works fine. offset setting should be on 0 not 0.5 … doing the raw input for some reason broke my particle sprites and they would no longer tick before play, I had to migrate my whole project into a new one to fix it, now I’m scared to try it in the fixed one hahah :D… ugh this game dev stuff is hard. thanks for your help friend!

Then ue4 doesn’t support ps4 contrllers by default, a quick google led me to this topic which might work for you:

Yeah that’s what I tried to do which pushed me over the edge and I asked this forum what was going on. I had all of those settings set up right but when I clicked play the camera would spin to the right infinitely and my character would run forward endlessly unless I pushed up on the left stick. It’s like the input setting didn’t scale right for some reason, so annoying. Like instead of the idle being ZERO the idle was 1 instead. Thank you for your time and help by the way.

Yeah now there is 5 members in the raw input plugin, now they have an option to check true if input is a gamepad stick. I tried messing with the settings with the box checked off and with the box checked on. I just downloaded 4.25 and tried it and still have the same problem. How can so many games come out on playstation that were develped in ue4 and no one else has the same issue. I don’t want to get an xbox controller because I want to develop the game to release on playstation as well, I think I’ll have to make a new character and game states from scratch which will eat up a lot of dev time but if that’s how it has to be so be it!

haha glad that it worked it self out :slight_smile:
Don’t forget to mark this as solved so if anyone else as issues with ps4 controllers in 4.24 they can find your solution

Here also due to older tutorials no longer working after the “Gamepad Stick” box was added. You said you got this working, but if I setup like your previous screenshot except with offsets at 0, then my character spins infinitely. At 0.5 it stops spinning but I can’t move. Maybe a new screenshot now that you have it working?

I think there are 2 different hardware IDs for PS4 controllers. My PID was different, but the VID was the same. By just putting in the VID and not the PID, it worked. (I’m sure I could have locked it to just that version of the controller with the correct PID from the hardware manager, too.)

I ended up with 0.5 but not using “Gamepad Stick”, like the answer said.