Can I have a skeletal mesh play 2 animations at the same time?

I have one of the Maximo characters but I’ve got him setting down on the ground with his nee up and an arm draped over it. I wanted to make a simple animation with him so i figured I’d just use the record button, considering I really don’t know what else it’s for.
I made a simple animation of him tapping his foot on the ground.
And I made another one of him turning his head a few different directions over a period of time.
Is there a way i could get both of those to play? or was there another way I should do this??


Hmm not sure what you’re trying to do, but to mix animations together and blend them, you can use Animation Montage,
there you also set the SlotName (for example UpperBody), so that in CharAnimation Blueprint you can set up a node UpperBody that will affect only upper body, this way you can have for example base animations that drive your character and at certain events you can override animations on UpperBody part only.
Nice example tutorial : - YouTube

Thanks for the response.
I only see them them blending tutorials over a specific time frame in this one.
Once again. Blending them completely is what I’m trying to do.
You have an animation of someone tapping there foot.
Another animation in the same stance moving there head.
How could I get them BOTH to play at the same time?
I can line them up in a montage like this. I’ve done it. But they don’t play at the SAME time.

I see what you mean, yes I tried and looks like the animations can’t be blended but played one after another, and if you add another Slot to Montage and a new animation, I don’t see any settings for blending per bone or anything like that, the first animation simply overrides everything else.

Well maybe if you would try to blend per bone like in the video:

Jump to about 06:00 and watch from there, he created BlendPerBone slot and names the bone to blend, so he blends both animations, I didn’t try it but it looks like this should work.

Also to time it all pefectly you could make 2 montages out of your 2 recorded animations, you can add a Montage Section to the track and name it, so that can help specify where your animations start playing (using PlayAnimMontage you can specifiy “Start Section Name” ). You could even use AnimNotify on the base animation to start the 2nd animation at right time.
I hope you can make it work, good luck :P.

Hey again, just occurred to me this could be done inside the states as well, so I went and tried that and it worked , here’s the screenshot what I did:

Oh dude that is awesome thank you so much!! I’m 100% sure that will work for what I need it to do! I’m trying it ASAP! thanks AGAIN!!!

You’re welcome :smiley: !

ACTUALLY…I finally got to try this and it didn’t work…
It only plays the top animation in the little view-port window even though it shows in on the canvas in the nodes that both are being played…

any idea???

Have you tried changing the Blend Weights to 0.5?

yes i have. i have changed the blend weight a few times. I’m using a maximo character. I made simple animations with the record option in Persona. Both animations work, but when I put them together this way only the top animation in the chain works.

Hey hey again, well as I said I tested this with my custom character and animations and it does work, you have to make sure your character blueprint is using the correct animationBlueprint, so recheck that, if it does you should see the animation play in the Character blueprint too. Next make sure you entered correct bone names, you can also copy the name from editor, I would also suggest you make the foot animation for base animation, and blend in the head animation, meaning you need to enter neck bone name into the blend per bone node, and that should do the trick. I didn’t change any of values for Blend Weights, it works right away as I did that like in the screenshot above.
If in doubt you can always go back to watch the tutorials (links above).

What I find nice about this method is that you could actually have several states set up like that, and could just switch from one to another.

I was just putting the animation BP out in the level.
I don’t need the bp to do anything but animate anyways so I figured that would be ok.
When I’m looking at the animation BP and I set both animation into the node and plug it in and compile it only shows my model doing the top animation.

Seems like the editor recorded animations don’t play if you plug them into the “Base Pose”, you need to make it like this instead:


I do appreciate everything you have done to help it is truly great of you. I did try this, it seems without something plugged into the top input nothing works, whats happening is the node is ONLY reading what’s in the top node…I tried setting a bone into one of the bone names like you said…I didn’t get a change.
I’ll continue to try and figure this out, I may be putting the bone names in wrong but i literally copied the bone name over.

Tell me which character you are using, and I will try it and see what happens. May be the issue is those characters are not compatible with 4.7 version.

Sorry for the delayed response.
I’m using Ganfault. The dude that is half mutant or something.
I have him setting down with a knee up and an arm over it. nothing too major. thank you again so much. I’m gonna mess with it some more now.

Ok I tried it, it works, what I did:
I added Mixamo pack to a project 4.5.1 version, cause it’s not compatible with 4.7.2…
Then I opened the project selected the Mixamo folder and “Migrate” it to some other 4.7 project, then I double clicked on the Character Skeletal Mesh,
and created the 2 animations, moving head and tapping foot.
I opened the Anims/MixamoAnimBP_GanFaul’ ,
and opened the “Idle State” to add nodes, once finished I saved and dragged dropped the Blueprint’/Game/MixamoAnimPack/Mixamo_Ganfault into the game, and here are the screenshots:

This is excellent. It’s super close to how I did it but it’s a little different. I’m gonna try this this evening and I’ll let you know. Whatever node you have in the top of that layer blend per bone node is definitely going to help. Thank you so much!!! I’ll be back shortly