Can I check if my blueprint is properly loading in package?

On Event BeginPlay I am calling a custom action from Blueprint A to Blueprint B. It works when I play in a standalone game from the editor, but on package it does not work.

I read there might be an issue with DefaultEngine.ini not updating if a name gets changed for a blueprint, but I haven’t been able to make sense of it.
I also tried adding in the folder that holds the blueprints to “Additional Asset Directories to Cook” in the Project Settings > Project - Packaging, but that did not seem to solve it as well. I’m not seeing any issues in the output log as well. Is there any way to easily check if the Blueprints are properly being packaged? Could something else be causing the issue?

Amazing, the delay worked perfect. I’m going to record to loop like suggested.
I’m not seeing an option to mark your comment as correct, but it is

The timing can be different in the various stages of packaging. Try putting a delay after the begin play.

If that does work ( and you’re not happy with guessing ), then you need to re-code that part so that it loops waiting for the actor to appear, rather than assuming it’s presence.

( I don’t know if you’re spawning or what … )

Jolly good :slight_smile:

You can make a ‘while delay’ macro which waits until the actors are visible…

( I converted to an answer :slight_smile: )

You can wait like this:

Macro definition: