Download

CameraFade

Hi can anyone tell me why when it gets to the camera fade it will not animate. It seems to stop on the first frame of the start camera fade and will not play the fade animation at all.
If i have the first alpha set to one it will blank out the whole screen so i know its activating just for some reason it stops animating.

625ef592e6bdb27c24be9ec8236740601adee1d4.png

Thanks

Hey there just tried it myself didn’t know this was a feature lol but I noticed you got a couple things off.

674a927424791722101f4b6ac8ee7efe388efd5b.jpeg

Just use these settings and you should be ok :slight_smile:

i did all that but it wont play it. It only does the first alpha setting then will not animate.

This is what i did and all works well but the duration of the fade so add in a delay for the time to hold screen as “White color” then do your respawn function.

Here is where you check players health(Mine runs on a tick in characterBP), when 0 or below call custom event.
aaad29e6a7ea06e1eca8210fa8290a84859e8806.jpeg

Here is where I made custom event. Like I said all works well but the fade timer I even tried a timeline to no success.

Hope this helps!

Yea its the delay thats the problem. For some reason i cant get another delay for it nothings showing up. It says it cant be opend within the function. Any idea why?

Delays can not be added to functions(Not sure why but they don’t) this is why I made custom event outside of the function to run the delay then run your function after delay.

I put it on the main tick after everything else and for some reason even with the delay it is still only activating the first frame of the fade and not continuing on from the first alpha value, really confusing.

Can you post screenshot of your BP’s please so I can see what is where? This will help me help you :slight_smile: