CameraBoom has to be 'Movable'

um… I did not make this static, there is no option to make it static, it is not parented to a static object…

Performance:Warning: Warning Mobility of MyCharacter_C_0 : CameraBoom has to be ‘Movable’ if you’d like to move.

I get this and camera refuses to move. no idea why. can a material interfere with a parent’s component settings? because I had this crop up and I was just tweaking material settings.

just an update. possibly re-creatable bug to do with parenting and static/movable switch in component view.

If you have a camera boom with a camera parented to it, and you make the camera static, it is possible to somehow make the camera boom become static.
because there is no way to change a camera boom from movable to static, it becomes busted and broken, to fix you must replace the boom with a newly created one.
mainly just an inconvenience, but it could still be an issue for some people.

Hi Fenrix,

Which version of the editor are you currently using? I haven’t been able to reproduce what you’re seeing. Above you said to change the camera from Mobile to Static but in the MyCharacter blueprint Component that option is only available on the Capsule Component.

4.2 just managed to reproduce it, heres how.

on a 3rd person blueprint project.
place a static mesh and parent it to the camera boom.
set it to static.
set it back to movable

camera is now broken because the camera boom has been changed by the static mesh for some reason.

Hi Fenrix,

I’m sorry I haven’t gotten back to you in a while. I still haven’t been able to reproduce your issue. Are you testing it in a new 3rd Person BP project? And if so, have you tried it in 4.2.1 or 4.3 yet?

just re-produced it in 4.3

On a new project, 3rd person blueprint.

in my character blueprint,

in components tab.
add “static mesh”
drag the static mesh onto the camera boom (spring arm) to parent it.
set the static mesh to “static” (just below the location,scale,rotation section)
a message appears saying it changed one components movement settings
set the static mesh back to movable.

and now the camera will not rotate because the spring arm is now bugged out and cannot be told to be movable.

and video because I had some time over lunch.

(its probably not something most people would do but the fact that setting something to static can change it’s parent’s movement settings and leave you no way of changing them back is probably an issue.)

Hi Fenrix,

Thank you for the feedback. I was able to reproduce the issue and have submitted it to our developers to look into.

Thanks, TJ

Hey just want to comment this is still an issue. Once child component is set to Static it permanently changes the parent Spring Arm and Camera component to Static, requiring a new Spring Arm and Camera component (and all the blueprint references) if you want to revert back to Movable. Undo doesn’t revert it either as the parent components are changed under the hood I’m guessing? A little headache but still worth a fix please!

I am also getting this in 4.11 preview 7. Have the developers looked at it? Is the core issue known? Any chance of getting that information? I’d like to fix it and submit a pull request.

It’s a really painful bug to encounter.

I cleaned my solution in VS and rebuild but still got the issue. I’m not sure where the issue is in the engine.

Hi Bino,

This is still an open issue in our system but it has been backlogged due to other priorities. If you would like to fix this and submit a pull request, that would be great. Just make sure to mention that the fix is for JIRA UE-3551.




I managed to find a solution, what you have to do is to create a component (in my case it was a cube), set it to static and make it the root, then change it to moveable. This will also make the SpringArm moveable. Then you can set back your original root, and voilà: its working :slight_smile:

Workaround to this issue:

  1. Select the problematic mesh in the Blueprint viewport
  2. Set it to Static
  3. Set it back to Movable
  4. Compile and run the project and the issue should be fixed.

I experienced this issue when parenting a few meshes to a blueprint actor in the World Outliner. Setting it to static and back to movable solved it for me.