Camera Rotation happening for no reason.

I Have a 2d Flick game where the screen view / Camera seems to be relocating @ 90 and not in relation to the camera? The character is a fixed building with a fixed camera set at 90 degrees (camera within the actor blueprint).

This has happened on multiple occasions in different scenarios.
For Example:
1.) I created a new map which was copied from the game Map, I added a Start Menu to this map and it worked fine, Then for some reason the camera rotated; then I added a .2 delay and it worked.
2.) Then I switched from using mobile preview to current viewport for a test and the camera switched again? after not being able to work this out for approx. an hour, I went for a walk when I came back it worked.
3.) I have three UI buttons which switch the ammo type. They are all the same button and in the same widget with the same commands attached (just relative to the ammo type). when I click the first 2 buttons the ammo changes and it works fine, Click the third button and the ammo changes but the screen view switches @90 degrees.

It seems to be relocating to the center of the actor, is there a reason for this happening, or is it a bug?
I have attached two images to show the difference.

Thanks in advance.

There .2 second delay is quite telling. It seems you have some initialisation that’s out of step. Are you sure your setup is happening in the order you think it is?