Camera Render Issues Using Take Recorder Takes With CitySampleCars in Sequencer

Hey Everyone. I’m still having a serious issue i cant seem to get past despite seeing this issue being resolved for so many on this forum.

My aim is to use Take Recorder to capture a driving animation with the Matrix CitySample Cars using the game mode, then bring this track into sequncer, set up my own cinematic angle and render it.

I have gotten as far as Rendering, and despite trying a number of fixes, sequencer continues to render the game camera attached to the car.

I would like to write everything ive tried but because im only a year old at this, i would appreciate if someone out there who uses this technique successfully could walk me through their process, or at the very least i would like to start a conversation with some people who are still experiencing issues despite trying everything theyve found online.

Please someone save me from this great sadness

Thank you

1 Like

Are you adding a cine camera into your sequence? Depending on your logic, certain things will show up in the render as if you play the level and they showed up. I find you need to temporarily break certain lines of code temporarily to stop them from occurring as they normally would in game because the sequence in the level treats the cinematic as if you’re actually playing and everything. That is if you want a different effect than in-game… I’m not sure if you mean it’s showing the game camera view or the actual camera and spring arm. If its the spring arm and camera maybe try setting it to hidden in game and turn off visibility…? It should be anyway really…

Thank you so much for getting back.

It definitely seems like an override issue.

I have used a camera I dragged from the outliner into sequencer, and based on online advice, I also tried creating one from inside sequncer. Neither worked.

I used a technique before that helped with a similar glitch, one were the camera would render in a different spot, or underground. I added a Camera Cut track to my sequence and attach the camera I wanted to render to it and it would then render correctly. That doesn’t seem to be the issue here, it seems to be switching to the camera attached to my character, in this case a car from the CitySamples pack.

The Spring Arm is not something I’ve considered yet, if i was to look at that or the attached camera, do you know of anyway to disable it temporarily.

If it helps, the shot is from a recorded take of me driving the car in game simulation mode, using Take Recorder, then I’ve dropped that take into a level sequence.

I realise some of my lingo might be wrong, but I’d be willing to post screenshots, or screen recordings of whatever necessary to help you understand better.

Again, thank you for your reply.

I think the sequencer is buggy and or some things don’t make sense because of the way it allows post processing out of the engine. You said play in simulation mode? I’m not sure, but I’m under the impression you need to play the level as you would normally to record the animation data.

If it’s working correctly when it’s added it to the sequencer you should save both the track information and the sequence itself at the same time because I believe they are actually independent from each other even though they go hand in hand.

When you play the sequence without having added a cine camera the player should just run along it’s track and the camera just stays there until you key in the movements to the camera save the track and the sequence again when you’re done.

There’s also a setting in the viewport upper left corner to select your cine camera or the default. That may be a culprit? Otherwise it seems very strange this is happening. It has a lot of functionality in it that could be anything lol. Otherwise not sure… but I wish you good luck!


The famous Matrix City sample demo from the Epic Game Marketplace records car driving with a take recorder. The problem is, after recording with take recorder my action is: I’m rendering with simulate physics off for the vehicle, but the movement of the car is incorrect. (It works fine when previewing, but anomalies occur when rendering.)

UE5 suddenly crashes when I finish take recorder, and when I finish rendering, UE5 suddenly crashes every time.