Download

Camera Distance Problem on different resolutions

Hey fellows, I’ve been working on a project for mobile recently, a few days ago I encountered a really annoying problem with camera and couldn’t solve it till now.
so everything is working fine on my viewport and I can adjust my Camera to work the way I want, but when I change the resolution of the viewport or try mobile build preview, my camera has a different distance from PlayerCharacter and it varies based on the resolution I choose, either it goes far away or to close to the player that I only can see his head. here is an example of it being far away(the Camera actually has to be closer to the player than this):
[IMG2=JSON]{“data-align”:“none”,“data-size”:“full”,“src”:“https://forums.unrealengine.com/core/image/gif;base64,R0lGODlhAQABAPABAP///wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==”}[/IMG2] ](filedata/fetch?id=1862437&d=1613328362) ​
I found out that enabling Constraint aspect ratio in Camera Component setting is exactly the thing I need, but the problem is that it automatically adds black bars on the screen which is of course not desired and ugly, So my main question is how can I achieve the exact same thing Constrain aspect ratio does without black bars? I already tried to convert Horizontal FOV to vertical FOV since at first I was testing my project on landscape mode and it seemed to work correctly but now I’ve changed it to portrait. this is what I have tried: https://answers.unrealengine.com/questions/451289/how-to-use-vertical-fov-using-blueprints.html
Thanks in advance!

Have you tried this solution? It is different from the one you have already tried, and this runs every tick instead of just once on BeginPlay.
https://forums.unrealengine.com/deve…891#post202891

If it works, have it run after whatever code is changing the aspect ratio.

I’m not familiar with mobile development, but couldn’t you determine if you need to convert HFOV to VFOV and vice-versa by checking what orientation the device is in?

thanks for your response I’ve already checked the link you put above that’s a different problem , I tried the link I shared above this morning again, and it worked ! I dunno why wouldn’t it work before. but now it’s working flawlessly I had to convert HFOV to VFOV.
if anyone has the same issue you can try this as well: How to use vertical FOV using Blueprints - UE4 AnswerHub