Download

Camera distance from Actor.. Improve Rendering and Scale !!

Hi All,

I am developing my first project in UE4 for mobile. It’s not a kind of roadblock that I’ve hit, instead its the quality settings that i need info on.
Ok so far so good, the issue that i face i that my camera is positioned about 3500 units away from the character, with a very low FOV.
I’ve setup a Stationery Directional light in the scene.

Now, when i bake lighting for movable objects (light as if static), which are already in scene, i get nice shadows.
I don’t get the same on the main actor. Why is that?
Also when i preview this in the iPhone5 and iPad, the block texture seems to get blurred, as if to have no information on it at all.
What settings do i need to tweak.

Also when i preview this on the devices, the edges are very sharp and rough. To an extent that the character seems invisible in itself and looks like a walking stick.
I have a requisite to keep the character this small. Can someone help me with how to get about with these issues in the editor.
I also read a similar post on shadows and rendering with options such as …

r.Shadow.FadeResolution - controls how big the light has to be on the screen before it starts to fade out.

  • Default Value: 64
  • Can lower this value to keep shadows from fading out at further distances

r.Shadow.MinResolution - controls how big the light has to be on the screen before it finishes fading out, at which point it no longer has cost.

  • Default Value: 32
  • Lower values seem to increase shadow visibility.

r.Shadow.TexelsPerPixel - Causes a higher resolution to be assigned and then it should fade out less aggressively

  • Default Value: 1.27324
  • Can increase this value to improve shadow rendering visibility & quality

r.Shadow.RadiusThreshold

  • Default Value: 0.03
  • A lower value of 0.02 or 0.01 greatly increases shadow visibility at far camera distances (seems to have the most impact of all the console commands).

I have no idea whatsoever on how to use these. Any help would be great?
Thanks.
Have a great day.

Screen Shot 2015-04-14 at 12.40.17 pm.png

This is the actual result i am getting.
Look at the cube and its material.
Everything seems washed out.

Its a movable actor… called into this position from another position.
I have it set as ‘Movable’ and in lighting i’ve checked it as ‘build light as Static’.

Hi kinzua01 ,

try this:
https://forums.unrealengine.com/showthread.php?64311-Jagged-edges

but maybe you have the same problem as me:

thanks 3DA.
Can someone help me with how to change the device profile config from within the editor.
I checked out the documentation. There are suggestions to change what all, but no where could i find how to go about it.
Thanks.

Hi kinzua01,

Is this the documentationthat you found? That is for altering the ini file that you can find for your own project. The folder location should be something similar to /UE4/YourProject/Config and you will find the ini in that folder. For more info about configuration files in general, please see this documentation.

Hope this helps!

hi wittlief,

thanks for the info. This is what i was looking for, somehow i missed the documentation on configuration files in general.
i was looking at the first link you sent, and was wondering where to tweak these settings. I could read these in the editor though.

Will make changes and post the results soon.
I still have to figure out the material rendering issues.

Thanks a ton.