Download

Camera collision problem

I’ve a problem when i creating a 3rd person game.
now i have a character controlled and an enemy in the scene.
the camera collision is on so that when the character is near the wall and the camera looks from the wall direction the camera will zoom to the character.
however,there appears the same situation when the character is near the enemy and camera looks from the enemy direction,the camera zooms to the character which is not i want.
i take a few screenshot and hope anyone can help me to solve the problem:D
character cameraboom setting:
cc1.png
enemy mesh and capsule collision setting:
cc2.jpg
cc3.jpg

Hello,
In component tab, select your “camerasprin” and in details / camera collision, uncheck “do collision test”.

1 Like

i just solved the problem by change the probel channel to ‘visibility’ and now the camera boom only do collision to the wall and not the enemy:D

I had the same “problem” and it turned out to be that the characters placed in the map do not inherit the change(ignore camera collision).
I had to just delete the old characters and place them again in the map.

It helped me too, thanks!!

It helps, thanks。

Is it possible to keep the collision without the line trace check? So the thrid person camera can’t clip through objects but doesn’t zoom each time there’s something between the camera and the character.