Download

Camera calibration plugin errors

Hello, I’m using the new camera calibration plugin to get lens information in 4.27, but getting some errors
I’m following the ue documentation on using the plugin, the camera calibration quick start guide, but in section 3 step 10 I get a serious issue.

I’ve calibrated the Checkerboard to match no problem, but when I walk they the nodal offset steps (click on the in camera trackers led light several times) and select add to nodal offset calibration, my camera is offset in a very crazy position.
I’ve tried this several times and what’s worse is it ruins my calibration and I can’t undo. I have to start from scratch with a new lens file because I can’t reset the offset. This is how far off the calibration is, and all I’m doing is pointing the camera at the real world tracker and on screen clicking it’s led light.

Also when I try to redo the nodal calibration, I get this error…

Not sure what this means, I’ve tried taking many points, a few points, moving the tracker and taking points from static camera, moving camera and taking points from static tracker, same error.

Further, I forgot to mention that when I go to do the nodal offset points method, I notice a bp ue tracker is preselected for me…

But this isn’t the bp ue tracker I have in my scene, this is a 2nd one. Should I be selecting my tracker from the drop down?


Where is this other tracker coming from?

Hey sorry I didn’t catch this sooner, I have two videos on setting up and using the 4.27 calibrator on my channel.
Recommend you watch them in this order, the tips video shows how to avoid the crazy camera problem you’re having.

Unreal 4.27 built in lens calibrator tutorial, how to make it work every time! - YouTube (Tips on using the calibrator)
Unreal 4.27 built in lens calibrator tutorial, great results with less work! - YouTube (end-to-end tutorial on using it)

The channel has lots of other Virtual Production stuff too…please like and subscribe!

1 Like

Saw these. Brilliant thanks Greg, that first week I ran into all the same problems you had mentioned, thanks for creating a clear tutorial (and yes I believe it was the first one).