Download

Call Custom Event in Level Blueprint doesn't work anymore?

Is it just a bug or epic stuff removed it or it wasnt available and if not. Why they put a check box like in the other picture “Call in Editor”? Well, if I check it, it doesn’t work for me.
Any solution for me?
089e2dcdc26422fa31dee79be045e45f40ff6eb3.png
f218e7777c7f4edc9f4a3fdd6e71f831f7c9170a.png

HI Mate

You can call customer event in Level. Turn Context back on, might help.

ef7d18bfe478319b315d97daa6c1ce5654f4f747.jpeg

Narg

For some reason it doesn’t work me. I tested it on the new build 4.8.0 and it works like a charm. well I am not sure what is wrong with 4.7.6 :confused:

Is 4.8.0 available in the launcher? I don’t see it, if so.

Also, I tried to simulate your problem but could not. I had Context Sensitive checked but I don’t think that should matter. Works fine for me in 4.7.6. Silly question, but have you tried restarting the editor?

Image taken from level blueprint
66f67d7c6df2afd5926c111342a00ab554abe3a6.png

Yes, I restarted launcher and pc. I mean the preview of 4.8.0. - Preview 1 o.O
I “fixed” it with creating a new project and mirgate all the files to the new project. And now it works with new project. I have no idea what was wrong with my project.

Because of that “bug” - (I don’t know it is or not) I almost gave up to using unreal engine. :confused:

PS. Enabling Context Senstive doesn’t change anything!

IMO UE4 is the easiest and most balanced engine around. I’ve tried a few and I ended up sticking with UE4. As far as bugs, well there can be some. I’ve had UE4 crash more times than I can count. Always when trying to delete unused content though…

But, it’s unusual to find a bug that can’t be replicated or isn’t resolved with a restart. I wonder if something else happened that perhaps none of us are aware to, like a setting change for example. None that I know of, but just a possibility.

Are you sure it doesn’t work for you? With the current implementation like that the blueprint needs to be an actor and placed in the scene. Select the actor in the scene and down the bottom in its settings you will get a “Blutility” section which should have all of your custom events that have call in editor enabled. You can’t call it from within the blueprint itself like that.