"cached variable property's owner is '/Game/CombatTest.SKEL_CombatTest_C'"

Hi, I’m having trouble with a simple actor blueprint class that, when the F key is pressed, gets two integer variables (HP and AbilityDmg), puts them through an int - int node, and sets the result to HP while also outputting the result to a Print Text node.

However, no matter how I set it up, it doesn’t seem to work - nothing outputs to the screen and no integers are present in the log. Furthermore, selecting the variables in the Blueprint Editor yields the message LogBlueprintUserMessages: CustomizeDetails for Blueprint 'CombatTest', cached variable property's owner is '/Game/CombatTest.SKEL_CombatTest_C' in the output log. (‘CombatTest’ is the name of the Blueprint.)

I’ve tried deleting the variables and recreating them, I’ve tried deleting the Blueprint Class and recreating it, I’ve tried creating a new project with the same Third-Person template I used for this one - all end in the same result.

Pulling my hair out over this one - is anyone else getting the same issue? Any help or feedback would be appreciated.