Download

Cached component instance data transform did not match!

Hi guys!

Having a little trouble here.

When I perform a cook on my game I get this warning:

UATHelper: Cooking (Mac): Cook: LogInit: Display: LogStaticMesh: Warning: Cached component instance data transform did not match! Discarding cached lighting data which will cause lighting to be unbuilt.

I have been trying to isolate and solve what is causing this issue but I have had no luck. This issue started after updating to 4.17. And since this warning started my iOS builds have been building properly but they immediately close right after the splash screen when I open the game on my iPad.

I have tried seemingly everything under the sun to resolve this. I have deleted both my intermediate and saved folders, that did not help.

I have confirmed that this error is appearing on both Mac and Windows cooks and on multiple computers.

I have attached both my windows and mac cook logs

It could very well be that the error message that I mentioned above and the fact that the game immediately closes right after the splash screen on my iPad are separate issues and not related. However they did start at exactly the same time so it is likely that they are related.

I have also tried creating an entirely new project and moving my content over to it and that did not help, the issue persists. I have also not ruled out the possibility that this is just a bug with the current version of UE as my project worked fine on 4.16.

I also build for Windows and Mac and both of them build and play perfectly with no issues.

Any thoughts? Any ideas?

EDIT:

It will not allow me to upload the windows log so I am going to post it beneath this.

It will not let me paste the windows log either.

Windows log:
https://drive.google.com/file/d/0B5kblhg6ie8TdFZ6Sm5oeTQ2Zm8/view?usp=sharing

I have also confirmed that this error message is not occurring on newly created projects.

I solved the issue of the game closing right after splash screen. All I had to do was go to Settings > iOS and put a checkmark next to “Cook ASTC texture data for Metal on A8 or later devices.” I am still getting that error message when I cook though. But it does not seem to be causing interference with anything though I am still going to try solving it. Any ideas?