Cable component disappearing on load

Hey guys.

I have an issue with the cable component. At first when i started using it, it went well and no issues. I was making a little hookshot from zelda in a third person game. Worked well enough for my little test.

I added a climbing system and a pushable block.

The pushable block i initially copied form another project but did not migrate it… I know that is bad.

After that my cable component now disappears on my player character blueprint.
I get this error attached. If i re add the cable it is fine until i close and open the editor again. Then i get the error again.

Is this a potential GUID error???

I tore out the pushable block and built a new one from scratch. Deleted the offending copied file etc.

I still cannot add a cable component. Any thoughts? I also tried adding this to my build.cs file. This didn’t fix it.

Wondering is anyone has an idea?

This is still happening for me (Engine Version 4.22.3). I’ll set up a simple blueprint with a cable component, and then when I reopen the editor later, it’s gone.

me too, so badly…

Hi there,
go to your engine installation namely to Engine/Plugins/Runtime/CableComponent and edit the CableComponent.uplugin file (you can do it with a text editor). Simply change the “LoadingPhase” variable to read “PreDefault” instead of “Default”. This way, the plugin will initialize earlier and the Cable components will load properly.

1 Like