Caannot Move in Z axis (Add Movement Input)

I have no clue why My 2d Sidescroller Character cannot move in the Z axis. I have disabled gravity,
I have set the normal walking mode to flying, The only locked axis is the Y axis and still it does not work. It works if I set the World Direction to X or Y but not Z. So it is not an input issue branch or Boolean issue it is just my Character refuses to move in the Z axis. Please help…

This may could answer your question.
Only Floationg Pawn Movement in pwan support to add movement input “up”.
Thanks to epic didn’t write it on document help us waste that much time.

Reviving this topic after 6-7 years as I had similar issue which I managed to resolve… to some extent.

In order to allow vertical movement in the Z-Direction, you need to set Movement Mode to Flying (make sure that the Can Fly boolean in the Character Movements component is set to TRUE. Then use the Set Movement Mode node to change the mode to FLYING.
The only thing is that the character literally will be flying and if you want to use this for climbing ladders for instance, you just need to use a boolean so that if it is:
TRUE (if overlapping with ladder) → Disable X/Y Movements & Set Movement Mode to Flying
FALSE → Enable X/Y Movements & Set Movement Mode to Walking.
Hope this helps