C4D House Builder Import Creating Extra Layer

Hey guys! This is my first message here. Thrilled to be in the community. I’ll get right to the point. I have been using U4 for about 10 days now and I have to say it is very comfortable for someone like me who has absolutely no idea what he is doing. I’m learning how to do stuff with online tutorials (tons of them out there so there’s no excuse), and fiddling with the system on my own.

I’ve decided to design houses with Cinema 4D house builder tool. It is fast and easy to get a grip on and use. Alas, I am yet a noob. I tried to import the fbx export into U4, but it created another plane layer right in the middle of the house. I assume it’s probably something I have to take care of at C4D before I export it, but there are no visible layers while editing in C4D. Any ideas what I’m talking about and what I probably did wrong?

Thanks for the help :smiley:

I solved it. The walls were also in line form. Turns out directly exporting from the house builder tool causes problems. As a work around we exported as 3ds, reopened it to free it from the editor’s shackles, and found that it slammed the ceiling (which was invisible while working in editor) into the middle. Fixed it there and exported again as fbx this time. Imported to U4 correctly.

Since it is a single mesh player can’t enter so now to set convex decomposition with perhaps accuracy to create the correct collision.

Still your insights on this are welcome as I’m probably still far from getting the results I want.

Abort: I had problems with collision. Going back to not using a plugin and building directly within C4D.


The end result.

Solved: Go to the settings and select “use complex collision as simple”. Make sure double sided geometry is selected.

Works like a charm. The only problem you will have is with textures so you might need to create the correct textures via 3ds or similar program as this is a single mesh and applying a texture from within U4 turns it into surreal art :smiley:

Now you can build your simple architecture from the c4d house building tool.

I kept updating my progress before anyone could write an answer just in case someone else who had these problems came along, in case you were wondering why I seem to be talking to myself.


It seems like my previous progress posts did not upload so here is a quick rundown.

1- Exporting directly from the editor put the invisible ceiling in the middle and made the walls paper thick and the edges not properly connecting. So we exported as 3ds file and imported it again, which ended the plugin version and turned it into a proper static mesh.
2- Exporting as fbx from there made the house look proper in unreal 4. We then had problems with correct collision. We did not need to do convex decompisition, the solution above worked and made the house properly navigable by the player.

You can use the “use complex as simple collision” but sometimes it’s better to use one of the other ways how you can create a collision: -> the “complex as simple” will “render” the building twice as it’s a per poly collision. So for larger objects it’s better to use a custom collision :slight_smile:

You have to give some time for people to reply.
Also there’s a possibility to edit your post, since most forums don’t like users to double or multi post.

As for your issues:
While it’s easy to create a house with the house builder tool, it’s not designed with export to game engines in mind.

This means you’ll have to edit some things manually to get it working right.

First of all (after you finished construction) you’ll need to make it editable, since the HouseBuilder is a phyton Generator Object that is based on splines etc.

Then i’d optimize the mesh and take out unneccessary stuff.

Instead of telling you how i did it, i just post a zip with the .c4d (R17) and .fbx file.


That way you can see how to set up the model for fbx export to UE4, too.
I’ve also built a collision mesh in C4D instead of auto generating one in UE4.

Pay attention to the naming convention:

  • UCX_meshname_01
  • UCX_meshname_02
  • UCX_meshname_03

Also first Tags should be materials otherwise UE4 won’t get the material selections right.
2 UV Tags, each with a different name, are also a good idea.
First one for the Texture/Material and the 2nd one for lightmaps.
Phong tag for the Collision model parts should be set to 180°.

Phong tag on the visible mesh, to whatever is suitable. (In this case everything under 90° will be fine)
Maybe you want to bake the phong tag of the mesh to a Vertex Nomal Tag for better compatibility, i recomend the Vertex Normal Tool Plugin.

In UE4 you might have to increase the scale of the Model, 4x worked just fine for me.
Also don’t forget to increase the size of the lightmap.
Since you have the whole house in one model 64x64 pixel are way to small.
Tested it with 1024, looked very good.

If you have any further questions or run into any problems, feel free to ask.
But be a little patient, i’m not online 24/7.

I solved the issues.

Now I have problems with the textures I placed while in c4d.

As for giving people time. I also looked around after posting so I updated to save others time :smiley: simple as that.

Kraid, thanks a lot for your detailed reply. I’ll try with the make editable and see what results I get there.

I used a house floor plan picture in the background and scaled things to an ideal size before building, then built the walls on top of that… The solution I wrote above solved all my collision problems. The character can walk around the house comfortably. The only issue I have left to solve is to import the house with its given textures correctly. Since this is my second week in this area and my background is literature, I am still trying to decipher your advice. For example, I could not figure out how you added those two UVW tags. I googled trying to find a solution. People talk about selecting the “generate uvw tags” option. For some reason that is always greyed out for me. You mentioned that tags should be materials, I didn’t really understand what it meant. I’ll add a screenshot. You’ll probably find a ton of things I did wrong :smiley: I’m beginning to feel like I would be better of doing this slowly on c4d instead of relying on plugins.

Bonus question: How do I add a texture to the outer walls?

Edit: After checking your file it felt like my problem is indeed the housebuilder plugin. Your objects look like they were created from the normal c4d editor. Or I might be wrong, I’m not sure yet.

Thanks . Are you saying it the level will perform better if I import just as the mesh without collisions and do them manually? If so, then yes that is something worth considering when creating a playable game.

Bonus question: How do I add a texture to the outer walls?

You go into polygon mode. and mark the outerwall… got to selection -> set selection. name it outerwall or whatever…
and assign a texture to it.
“Big note” after you have set a selection. set highlighter tag back to a Texture or a UVWtag. if you plan on marking more selections while the one of the selection tag is hightlighted. it will be overwritten.

Its hard to see from you picture what you have done. . I see a Bunch of Null object with textures on them.
Which is not the way to do things. “imo”.

I have used C4d. but never the house builder tool.
What you should do is mark the parent Null. rightclick and selcect all children.
Then hit current state to object. then strart to make a single. or as few meshes outof it as possible.
But again. its hard to see whats going on there since your only showing a bunch of nulls.

so you basically have 2 choices to get textures. “well actually 3 or more” but i’ll try explain my two.

The Lazy Way… involves no UvMapping. “Bake Texture and Bake Object”

Method 1.1. Create the model. Apply the texture to the correct selections. Add a Bake Texture Tag to your model.
To into tag and set texture size etc, channel. “I DO NOT RECCOMENT TO MAKE NORMALS HERE”.
Hit Bake Texture.
Remove all other textures from your model and apply the newly made. export the mode.

Method 1.2.
Make model. set up selection, apply textures set correct projection etc.
But now highlight you model in the Object browser. then in its menu and find Bake Object.
Setup the texture size. same as before. hit bake…
Now a new object is created instead which you can use and export.

My other method for static stuff
May vary based on what im doing tho but for static stuff (no animations and such).

  1. Make model ofc.
  2. Optimize model. remove polys never seen. connect several object etc.
  3. Setup selections around the model. apply tmp materials to them. “just to get a basic feel.”
  4. Uvmap.
  5. Create Textures.
    The Lazyway is not reccomended. altho it works well for simple things. but stuff should really be uvmaped properly and all that.

Thanks a lot. I think the problem is the housebuilder plugin. It doesn’t work well with all the methods described throughout this post. The outer walls are unselectable etc. I think I’ll stop using that tool and do it the traditional c4d way. Then, all of the advice compiled here will work and get me through it. Thanks a lot :smiley:

You can use the housebuilder tool, but once you set up everything the way you want it (rooms, doors, windows), you need to hit the “make editable”.
This will create a new object containing polygonal objects for walls ceiling and floor.

These objects need further editing with the regular modelling tools.

If you ask me, use the housebuilder only for the walls and insert ceiling and floor with the modelling tools.


  • remove top and bottom polygons of the walls
  • add thresholds with the bridge tool
  • fill polygon holes to get ceilings and floors
  • select the outer border in edge mode (loop select with borderloop checked) and do a zero extrude (extrusion with a value of 0)
  • scale it up in Y-direction (hold shift for getting 10% steps)
  • close the bottom and top with fill polygon hole tool
  • select and disolve unneccessary edgeloops caused by the extrusion
  • delete unneccessary points that might have remained.
  • set selection for the outer walls
  • create additional materials for floor, ceiling and inner walls and set their selection
    (you might want to hide some polygons like the top one and ceiling in order to be able to see inside, use the “selection>hide selected” in polygon mode for that)
  • drag&drop the polygon selection tag into the selection parameter of the material, repeat for every material
  • for UV channel 1 you can use simple cube projection for each material and do the U and V tiling of the texture in UE4 (this step is not included in the gif)
  • for UV channel 2, copy the tag once (ctr+drag Tag with left mose button in Object Manager)
  • do a box projection
  • disconnect the UV islands like in the
  • select all, then use the optimal mapping to pack the UVs with a spacing of 2% (if you want a small lightmap resolution you might even use higher values like 4%, but for 512-1024 2% should be fine)
  • since the top and bottom face only exist to block light and don’t need a high lightmap resolution, downsize them
  • repack the UVs, hit realign till you’re satisfied with the result (till there is not much empty UV space left)

That’s it for the modelling of the mesh, now you need to triangulate and export.

For a simple shape like this, having vertex collision is possible without issues.
Once your models get more complex, you will need to build collision meshes since the automatic CM generator of UE4 doesn’t always deliver the optimal results.
This means it fails at very complicated shapes, especially when there are holes in a model and/or needs way more collision model parts then a manually built one.

Also it doesn’t hurt to know how to build CMs manually.