Download

C4D export fbx file (No textures)

I’m a newbee in creating assets so every help is usefull.
Did a lot of reading on the internet but I guess I forgot something?

I’m losing my textures in UE4 when importing a fbx file?
Tried all kind of fbx export settings in C4D, 2010, 2016 etc…
But without succes.

Hope somebody can help me out?

Screen Shot 2016-05-11 at 14.53.51.jpg

Check your export settings of C4D as well as the import settings of UE4 if the checkboxes for export/import of Materials and textures are checked.
In R16/17 use the fbx 6.1 2010 since it is the most compatible one, that imports materials as well as textures, if these options are enabled on export/import.
In R17.048 I wouldn’t recomend the fbx 7.4 2014 on top since it crashes UE4 and also creates much bigger fbx files. (possibly includes textures directly into the fbx instead of creating a subfolder like the other versions do)

Hi,

All the settings for importing and exporting are fine.
Im working with an older version Cinema Visualize R15, gues thats the problem.

Going to try to place the texture in the same folder and the fbx, hope that works!

If possible tryCactus Dans fbx exporter.

Same here, tried every fbx import/export setting on R17 and the textures do not appear in UE…

This happens in newer versions of C4D as well. It did previously work about a year ago so I assume it’s actually a UE problem. In any case you can just open the fbm folder and drag the textures in once you’ve imported it, although assigning them all is a huge pain if you have lots.

Ok, it works. In R16 and R17

Here’s what must be set up:

  • Textures assigned in c4d in compatible ue format
    - Make sure to unwrap the uv’s - It may be silly but uv overlap could cause not importing the textures
  • Export only in 2010, 6.1 FBX format
  • Works in R16 and R17