C4D Datasmith Freezing while importing in 4.27.2

Datasmith C4D is continually freezing on import. Importing any C4D project (literally just a cube) will freeze UE around 70% while importing. Creating a new project didn’t help. I tried uninstalling and reinstalling 4.27.2 and the results were exactly the same. Datasmith C4D in UE5 works fine however. Has anyone else run into this?

1 Like

Hi Kylemcc2007 !

Can you send us the C4D file here or at antoine.guillo(at)epicgames(dot)com so we can have a look ?


Having the same issue with UE 4.27.1

Importing datasmith freezes. After freeze and restart Editor, importing via datasmith stalls on Importing Cineware Modules at 0 percent.


For those with the same issue I still don’t know what caused this but I removed all C4D PBR materials with base, joined as many objects as I could, and froze transformations and it works now. My guess is it was most likely the PBR material that was causing issues but I can’t be certain.


Turns out I can import now, but only once. Then I have to reboot my machine in order for UE to do it again. Always gets stuck at Initializing Cineware at 0%.

me too! Datasmith freezing at 0% after the first import then you need to restart in order to import again, so infuruatinggg!

I was hoping this was fixed in UE5 preview 2 but not same issue

你好 我也遇到了相同的问题 70%或者0%