C++ variables not showing in Blueprints

I created a Blueprint child from a C++ class but I can’t see declared variables .


Do you have “show inherited varibles” checked?

You are looking in the wrong place, you will never see variables shown on that section of the BP, only vars that you created outside of code can be seen here, you have to check the right side, in the class defaults to be able to check those vars.

Yes, I have that checked but still can’t see them

I can’t see them even on the right side.

Hmm try adding EditDefaultsOnly to the UPROPERTY data

Tried it, but it didn’t do anything. I also installed UE4 on my laptop and tried if it’s going to work there and it works. I can see all my variables in blueprint. But I noticed my build output is different on my PC and on my laptop.

Build output from laptop:

Build output from PC:

I know this post is old and this was not your problem (because I can read the magic word that was causing my problems in your code) but I got here looking for this solution so I think this could be useful to other users.

I’ve created a lot of classes without problems, but this time I forgot to add 'blueprintable" between the class parenthesis. If you make variables BlueprintReadWrite but you forget to add this word you get no errors from compiling but nothing will show up…

I wish this answer was here when I needed it, I also downloaded e previous version of unreal thinking it was a bug in 4.26.2 (Because until last week it was working fine with 4.26.1), I think I will never forget how I wasted these 3 hours…

1 Like