Download

C++ Project Compilationr Error , missing mspdb120.dll

Hey,

I’ve already posted my problem to the ue4 answerhub mspdb120.dll missing on computer error - UE4 AnswerHub
Couldn’t find any solution, in other posts with the same problem.

Anyone can help?

~Slei

Might wanna post this under: https://forums.unrealengine.com/forumdisplay.php?9-C-Gameplay-Programming

Yep, that’s a better place for it -> I have moved it into the programming section :slight_smile:

I’ve managed to get rid of the mspdb120.dll error, by putting in into the system64/system32/system folder ._.
but still getting the error:
->each time when I try to compile the project, I get the Question dialog: “Project moduls are missing or out of date. Would you like to recompile them?” then unreal engine is loading them. (pressing OK)
-> error appears: “Game code couldn’t be compiled, Continue trying to start anyway?” (pressing OK)
-> and “The game module ‘MyProject’ could not be found. Please ensure that this module exists and that it is compiled”

Anyone can help?

~Slei

Yup, I had the problem too, and somewhere foudn the solution. Open the proejct in vs, Go to Project Properties -> Configuration Properties -> VC++ Directories and set all options from executable directories to library winRT Directories to “inherit from parent”.

hi
you can set compiler things by vcvarsall.bat just take a look at MSDN. it might help.
I have this problem only when trying to compile from the editor. still not resolved after many trials, so it seems to be caused by the VS2010pro present on my pc too, beside vs2013ee. compiling from VS is fine so maybe I have to live with it…
do you have other version of VS installed ?

didn’t work for me :frowning:

no just Visual Studio 2013 Express 32bit
re-install also didn’t work (VS first, then ue4)

Do you have the VS120COMNTOOLS path variable set?

%VS120COMNTOOLS% to
D:\Programme\IDE\Visual Studio 2013 Express\Common7\Tools

any other solutions?

~Slei

Win8 re-install fixed the error! :stuck_out_tongue:

Hey guys !

I have the same problem today, but as I am quite a beginner, I didn’t understand most of the solutions above… to

As I try to open my first project using the Puzzle in C++, I get the message in which msodb120.dll is missing.

Here is the log it gives me when the file is not found :

The project failed to compile with this version of the engine. Build output is as follows:

Running C:/Program Files/Epic Games/4.7/Engine/Binaries/DotNET/UnrealBuildTool.exe Puzzle Development Win64 -project=“C:/Users/Cédric/Documents/Unreal Projects/Puzzle/Puzzle.uproject” -rocket -editorrecompile -progress
Parsing headers for PuzzleEditor
Reflection code generated for PuzzleEditor
Performing 10 actions (4 in parallel)
[3/10] Resource Puzzle.rc
[2/10] Resource ModuleVersionResource.rc.inl
C:\Program Files\Epic Games\4.7\Engine\Source\Runtime\Core\Resources\Windows\ModuleVersionResource.rc.inl(3) : fatal error RC1015: cannot open include file ‘windows.h’.

C:\Users\C?dric\Documents\Unreal Projects\Puzzle\Source\Puzzle\Resources\Windows\Puzzle.rc(8) : fatal error RC1015: cannot open include file ‘windows.h’.

-------- End Detailed Actions Stats -----------------------------------------------------------
ERROR: UBT ERROR: Failed to produce item: C:\Users\C?dric\Documents\Unreal Projects\Puzzle\Binaries\Win64\UE4Editor-Puzzle.dll
Cumulative action seconds (8 processors): 0,00 building projects, 292,43 compiling, 0,00 creating app bundles, 0,00 generating debug info, 0,00 linking, 0,00 other
UBT execution time: 306,84 seconds

I tried to install the distributables but it did not help… Does anyone have an idea as to how to fix this problem ?

Thanks !
Cédric

Cédric, your user name contains an “é”, this can cause problems, just use another path like C:\UE4\ for your projects. But in theory it should work since 4.7.5 or 4.7.6, as I took part in fixing the hot reload related issue (reporting/testing) that was also in connection with user names containing non-ansi characters, but not tested it (hot reload uses another compiler as I remember, so it can still be an issue)

about the mspdb120.dll error: in my case no Win7 reinstall needed, no PATH settings helped at all, I just uninstalled VS2013EE, VS2010Pro and several WindowsSDK hiding on my PC. it was tricky to do in reverse order and all the related stuff, but not impossible, check install dates :slight_smile: (e.g. you cannot uninstall some updates afterwards, I also have a few ones remained) then installed VS2013Community and everything works fine (I gave this info at answerhub too).

Thank you for you answer !

I will try to do so and keep you updated =) (I’m in china so downloads and so can take a little time)

I unsinstalled everything, then reinstalled vscommunity but it still didnt work, so I uninstalled it again, and tried to install again VS for windows desktop but still nothing…

I start wondering if I should not installe Win7 again ^^ Just one question, if I do so, do I loose everything that’s stored in my computer ? If yes, even if it’s not on the local disk ?

If you have other solutions I’m all ears, I really like programming and would like to learn how to create games =)

do you set VC++ Directiories in VS/Project/Properties ? I always have to choose “inherit from parent or project settings”, because 1st time tey are empty.

The thing is I don’t even know what you’re talking about… What are VC++ Directories ? What is it for ? What do you mean by “setting” them in VS/project/properties, which I did not even find in the Visual Studio folder…

open the project,

in the Solution Explorer (where your project folders and files are represented as a tree), right click on your project (should be bold),
and click “Set as StartUp Project”,

then in the “PROJECT” drop down menu select “Properties”,
in the window appearing click on the little arrow beside “Configuration Properties” to extend it,
select “VC++ Directories”,
and there you should click on the empty lines, and select from the appearing 2 options “inherit from parent or project defaults”,
when all done, click Apply and OK.

save it, and you can compile it (e.g. by right click on project name in solution explorer and select Project Only->Build Only YourProjectName)

hurray! :slight_smile:

Omg it works !

Thank you so much ! Now I can go on with learning C++ by creating Games ! =)

If you need anything feel free to contact me, maybe I can help ! :wink:

okay, just make me some hundred high quality low poly animated characters :smiley: