C++ Function Not Visible In Blueprints Editor,CPP Function Not Showing Up In Blueprint Editor

You sure you know how to use CustomThunk? Since you did not provide the Important parts I assume no :stuck_out_tongue_winking_eye:


Remove everything in your UFUNCTION except BlueprintCallable and Category=“XYZBPLibrary”


I am a newbie in blueprint scripting. Here’s a small function I have written in C++ in custom class which is extension of usual BlueprintsFunctionLibrary.

It however doesn’t show up in Blueprints Editor. I see there are tons of questions in Google related to that and I have tried out a few solutions mentioned there such as -

  1. Close the editor and reopen.
  3. I looked inside example code of KismetArrayLibrary (.h and .cpp files) and made sure that that it maintains syntax similar to that library.

I am still digging through answers and trying to find a logical reason for this. However I am stuck for few days now and any help is greatly appreciated.

Thanks in advance…!

.h file :-
// Fill out your copyright notice in the Description page of Project Settings.

#pragma once

#include "MatrixUpdate.generated.h"

class UMatrixUpdate : public UBlueprintFunctionLibrary

	UFUNCTION(BlueprintCallable, CustomThunk, meta=(DisplayName = "Matrixupdate", CompactNodeTitle = "MATRIXUPDATE", ArrayParm="TargetArray"), Category="XYZBPLibrary")
	static void MartixUpdateOnInputStrokes(const TArray<int32>& InArray, int32 Command);	


.cpp file head :-

// Fill out your copyright notice in the Description page of Project Settings.

#include "KismetArrayLibrary.h"
#include "MatrixUpdate.h"

void MatrixUpdate::MatrixUpdateOnKeystrokes(
	const TArray<int32>& InArray,
	int32 command



Thanks for your suggestion. I actually kept it the way you mentioned. (Tried it once more). That doesn’t seem to make any difference…

Yes, I am still learning very much.

Uhm well at this point I just have to Ask: Did you Compile your C++ Code? I dont see anything wrong there.

They are pretty straight forward.